Question GPU Not Being recognized by computer at all.

Jun 15, 2019
13
0
20
3
Motherboard: z170x Gaming 5
GPU: gtx 1660 (6GB)
CPU: Intel i5 7600
Ram: Corsair Vengeance Lpx 16gb (4x4 Gb) DDR4 2666Mhz
Power Supply: Corsair Vs650 (650 watt)
Bios Version: f22f (Latest update)


Hello, with my old card seemingly dead, I decided to buy a new one. However, it cant be seen by my pc, the 8 pin is plugged in, and fans are spinning, yet it doesn't come up in device manager or anywhere on the pc, its like it gives it the power it needs to work without acknowledging it. If I plug my HDMI into the GPU itself then it get no signal on my monitor, I have to plug it into my motherboard in order to get a display. Any help is appreciated.

Things i have tried with no success:
-Resetting Cmos
-Disabling integrated graphics in bios (No display at all will have to reset cmos in order to get it working again)
-Disabling integrated graphics in device manager.
-Changing PCI-e Slot and changing default in bios ( I have 3, none seem to make a difference)
-Trying a different 8 Pin connector.
-Install drivers off Nvidia Website. (Fails due to no compatible hardware detected)


Again, any help is much appreciated, Thanks!

Luke x
 
Last edited:
Jun 15, 2019
13
0
20
3
Make and model PSU? Wattage, age, condition?

Test both the original GPU and the new GPU in another known working computer. Determine if either GPU works even with minimal configuration settings.
Thanks for quick reply, sorry i forgot to add the power supply but I just added it, (Power Supply: Corsair Vs650 (650 watt)) I don't have nor know anyone with a computer which i can test the GPUS on, but my old one had had problems for a while then it started getting the screen glitches, which you normally get with dead GPUS then it didn't work. hence why I presumed it had died.
 

ASK THE COMMUNITY

TRENDING THREADS