Question GPU not being Registered by pc

Mar 18, 2019
7
0
10
0
Hello! Im brand new to building my pc. and I put it together with help of my cousin who had built his Own computers. anyways to the point, My computer is only registering the integrated Graphics, Instead of my geforce gtx 1070 8g whenever I go onto the nvidia website to install the drivers, It stops the installation, Saying that i need an nvidia Card to install the drivers, But my gpu is nvidia. Any Idea how I can fix this? I mean my gpu is lighting up and powered and connected properly.
 

boju

Titan
Ambassador
Can ya list your pc specs plz

Pcie supplementary power plugs are connected i assume? Check plugs both ends between psu and gpu if psu is modular incase one was missed. The slot gives 75watts of power enough to light up and spin the fans.

Are you getting drivers from here? https://www.geforce.com/drivers

Double check video cable is connected to the graphics card's video port and not mistaken for the motherboard's.
 
Mar 18, 2019
7
0
10
0
Can ya list your pc specs plz

Both pcie supplementary power plugs are connected i assume? Check plugs both ends between psu and gpu if psu is modular incase one was missed. The slot gives 75watts of power enough to light up and spin the fans.

Are you getting drivers from here? https://www.geforce.com/drivers

Double check video cable is connected to the graphics card's video port and not mistaken for the motherboard's.
CPU intel i7-6700k @4ghz ram. 8gb ddr4, Windows 10 64bit Psu 600 watts. GPU geforce gtx 1070 gameing 8gb lights are on but fans arent spinning on gpu the plugs that are in is the pci-e 6prong plug that plugs into gpu
 
Mar 18, 2019
7
0
10
0
Oh ok, can i have the psu model please.

Try use two separate pcie cables on their own. Power supplies with daisy chained plugs are usually found on 750w psus.
my psu is a Glacier Gaming Power Supply 80plus bronze 600w From Rosewill model number is Glacier 600M
 

ASK THE COMMUNITY

TRENDING THREADS