GPU not detected after windows 10 update

jzo123

Honorable
Jan 24, 2014
16
0
10,510
0
Hi,

I have been using my computer for some time, and windows 10 has come out and I was looking forward to using it but it turns out my GPU is not detected. It was working before the update but now its not being listed in the device manager, instead all that is in Display Adapters is Microsoft Basic Video something. The GPU is a GTX770.
Help would be nice.
Thanks!
 

StarChief

Reputable
Jun 22, 2015
845
0
5,160
95
You need the drivers for that card for it to be recognized for what it is by windows. You can get drivers from the Nvidia website.
 

thauzar

Reputable
Jul 30, 2015
6
0
4,510
0
I have the same graphic card and I have the same problem. I downloaded and drivers from Nvidia but it says that it can't install them because it doesn't detect any nvidia hardware
 

thauzar

Reputable
Jul 30, 2015
6
0
4,510
0
intel hd graphics 4600 is what appears in my case, so it seems like win10 doesn't want to recognize my graphic card and the drivers wont even install because it's not recognized....
 

jzo123

Honorable
Jan 24, 2014
16
0
10,510
0
Yeah, as StarChief said downloading the drivers manually worked. Things are now working as they should. Thanks!

EDIT: It turns out that my computer did not recognise the graphics card until I removed it and rebooted 3 times. Then I was able to install the drivers for it to work.
 

Calvin Yak

Reputable
Jul 30, 2015
2
0
4,510
0


Im running a GT 610 and Getting a new driver does not work. my Graphics card is still invisible to the OS
 

thauzar

Reputable
Jul 30, 2015
6
0
4,510
0
I checked on alienware's (Dell) website to get up to date drivers for the manufacturer. The only update availlable was a BIOS update. I did it, and voilà! I could then install the most recent drivers from nvidia's website. Issue fixed.
 

gendelo3

Reputable
Jul 30, 2015
1
0
4,510
0
Can confirm that BIOS update worked for the same exact problem with my GTX 670.

my motherboard is the P8-Z77 LE PLUS by ASUS
 

Halfmooner

Reputable
Aug 4, 2015
4
0
4,510
0


I've had the same problem since upgrading tonight from Win 8.1 to Win 10. Worst thing is that the latest supposed "Windows 10" NVIDIA driver installation package tells me I don't have a compatible OS, ending the driver installation. Suggestions given here were kindly given and appreciated, but not useful.
 

tham1010

Reputable
Jun 1, 2015
6
0
4,510
0
I think I have a solution. You should let windows update the driver for you. NVidia updated most of its drivers to be combatable with windows 10. Here is the way.
1- in the search box write " check for updates" and choose it
2- you will see windows checking for updates. If you can see Nivadia driver" as one of the recommended update so let the windows update it. Keep your PC on till it is done downloading and installing.
3- restart your system and check if your computer can detect it.



In case you can not find any updates to your drivers in you " check updates" so go to the website and download a driver for windows 10 and install it.

** when you install your driver manually choose "clean installation option" so the driver remove any pervious old driver before installing the new one>>

Good luck
 

Halfmooner

Reputable
Aug 4, 2015
4
0
4,510
0



Thanks for the above advice. Problem 1 is that Windows Update does not see the need for a graphics driver, and considers everything up to date. Problem 2 is that after manually downloading NVIDIA's supposed Win 10 driver package, it fails after saying my operating system is incompatible. Have checked my MB BIOS, that's up to date.

The NVIDIA driver I tried today is "353.62-desktop-win10-64bit-international-whql." Today's "Problem 2" is, after compatibility check, a message that says I must reboot and try again. This procedure turned out to be an endless loop. My system uses an ASUS P8H61-M LX3 PLUS motherboard, an I5 CPU and a Geforce 630 GPU. (Yes, there you have it: A poor man's somewhat out of date gaming system.)

My problem is that I'm trying to do everything logical, but Win 10 simply refuses to see my graphics card. I'm fairly sure the problem is with Microsoft, not NVIDIA.
 

Halfmooner

Reputable
Aug 4, 2015
4
0
4,510
0
I seem to have fixed my problems. Display is now at my monitor's full, undistorted HD. I went to Settings/Devices/Device manager, and found NVIDIA Geforce GT 630 listed as a device under Display adapters. Under Properties, it was disabled, so I enabled it and rebooted. All's hunky-dorey for now.

Thanks again to all those who tried to help me.
 

Richard Maloon

Reputable
Aug 7, 2015
4
0
4,510
0


 

Halfmooner

Reputable
Aug 4, 2015
4
0
4,510
0
Good luck with that, Richard Maloon, I hope that fixes things for you! My impression now is that when I decided to go forward with the free upgrade from Windows 8.1 to Windows 10, Windows Update somehow disabled my graphics card.

Hopefully, the people in Redmond will soon get around to fixing this problem, making such upgrades easier for people like myself whose knowledge of troubleshooting the process is moderate or nil.
 

Richard Maloon

Reputable
Aug 7, 2015
4
0
4,510
0


 

Richard Maloon

Reputable
Aug 7, 2015
4
0
4,510
0
I found the answer that works all the time. UNINSTALL win10 using the utility provided. You get 10 days to do that. In the meanwhile do more research. I am back with win 7 and my two displays.


R
 

bdg2

Reputable
Jun 27, 2014
3
0
4,510
0


The CD is extremely unlikely to include a driver installation package that's compatible with Windows 10.

Go to the NVIDIA website and download the latest drivers for the GTX770 for Windows 10 choosing the correct bitness (32 bit for 32 bit Windows 10 and 64 bit for 64 bit Windows 10).

You may also find some drivers you can download under, if I remember right, 'Settings' / 'Updates and Recovery' in Windows 10.
 

Mulletsoldier

Reputable
Aug 15, 2015
1
0
4,510
0
In case anyone is having issues, I have a potential workaround:

1. Manually download the second-latest NVIDIA Driver Package. (353.30, I believe.)
2. Change its install location. (Can be a new folder in Program Files, wherever.)
3. This later version should auto-detect your GPU. When it does, DO NOT custom install - install everything, and most particularly GeForce Experience.
4. Install and restart.
5. Load up GeForce Experience.
6. Let it auto-update all your settings.

Based on my experience, this workaround leaves you with the most comprehensive and fully functional NVIDIA Install.

Also, a bonus tip: I found that NVIDIA's network controllers were leaving me with a limited connectivity problem on my USB adapter; if you experience the same, go into adapter settings, and uninstall the network filter driver.
 

Infidell

Reputable
Aug 16, 2015
1
0
4,510
0



I had the same problem, with my GTX760. After hours of trying, I finally found the answer (which is quite straightforward and easy):
1) download the latest drivers at nvidia.com (but don't install yet)
2) uninstall all current nvdia drivers: in system -> apps & features -> scroll down to NVidia and uninstall all of them
3) execute the new drivers you just downloaded, hit manual install and tick the box that you want a fresh install (so it does not keep the previous settings) (could be that you have to untick the box, depending on the option given, but as long as the end result is a fresh install, your fine).

Done. This fixed it for me at least, hope so for you guys as well.
 

ITGuy21

Reputable
Aug 22, 2015
1
0
4,510
0
When I went into Device Manager and under Display Settings. I right clicked on the Microsoft Basic Display Adapter and selected update driver. It started downloading an update and then it saw my ATI card. Not sure if this works with nvidia cards but something easy to try.
 

DudeDieAlready

Reputable
Aug 27, 2015
1
0
4,510
0


Download the newest drivers on to usb then run them on the problem computer. Windows 10 will then recognize your gpu. Also check your time and date as that was also a problem for me. After this I manually activated once and it worked.

 

SUNDANCE KID

Reputable
Apr 29, 2015
4
0
4,510
0
I solved the problem by uninstalling windows 10. Then going into the nvidia control panel and in the physx settings choosing the gpu I wanted instead of auto. Then reinstalled windows 10. Hope this helps someone.