Question GPU performing bad

Oct 30, 2022
4
0
10
0
Hello guys !

I'm posting today because I have a wierd problem with my gpu since 2/3 days.
Firstly, I have a laptop, so it is impossible for me to swap graphics card, it's a Lenovo Legion Y540-17IRH, with a RTX 2060 and a i7-9750HF that runs on Windows 11.
I went on holiday for a month and did not use laptop for gaming, i only installed some driver updates with Driver Easy, and some Windows Updates. When I came back, I launched some games that used to run fine on my laptop (BeamNG.Drive, Assetto Corsa, CoD MWII, F1 22 and DCS World) and it ran like sh*t, all the games runs at ~20fps instead of the usual 60fps. I also noticed via task manager that my VRAM usage is blocked at kinda 50-60%. So i desperately tried everything to solve this problem such as :
  • Rebooting my PC,
  • Clean install of GPU drivers,
  • BIOS Factory Reset,
  • Cleaning my laptop,
  • Changing my HDMI cable,
  • Disabling Intel Turbo Boost.
I've had this laptop for 2.5 years and never had problems like these, only overheating in summer time. I'm actually out of options so here I am, asking you to help me.

I did a Benchmark if that helps too : https://www.userbenchmark.com/UserRun/56249989 which targets the GPU.

I am at your service if you need some more informations.

Merci ! ;)
 
If you open task manager while running a game, look for a program/s that could be taking up memory, cpu performance, etc. excessively. In your benchmark post it is saying something is running in the background using up resources. What power setting have you tried in windows?
 
Oct 30, 2022
4
0
10
0
Thanks for thge reply,

Nothing seems to take performance while I play, at least not in task manager. My power setting was set to Razer Cortex Power Plan, after i changed it, nothing happens.

I am considering going back to Windows 10, maybe that could solve some of my problems ?
 
Oct 30, 2022
4
0
10
0
Conversely, if one of the updates was to the latest GPU driver, try with the previous successful driver you used.
I just tried that, clean install with DDU of an older version of my driver. After I restarted my computer, the game was a solid 60fps for about 5 minutes, and dropped to 15 fps.
 

ASK THE COMMUNITY