Question GPU plugged in doesnt give display

Jan 26, 2021
21
0
10
0
So my gpu is plugged into my mobo as firmly I could. However the fans dont spin and gives no display and when i remove the cord and plug it into my integrated graphics it gives display. I can’t tell what the issue is, dont have parts to check, is it a bios problem? Afaik if gpu is plugged in I shouldnt be able to use my integrated graphics
 

AlexTheFern

Upstanding
Jan 21, 2021
483
110
390
7
If that doesn't work, if you know a friend or someone who has a pc, try plugging your gpu into their pc and see if it works. If it doesn't, its your gpu. If it does work, try taking theirs and plugging it into your pc. If that doesn't work, it might be your mobo.
 
Jan 26, 2021
21
0
10
0
If that doesn't work, if you know a friend or someone who has a pc, try plugging your gpu into their pc and see if it works. If it doesn't, its your gpu. If it does work, try taking theirs and plugging it into your pc. If that doesn't work, it might be your mobo.
Yes gonna look it up for sure! Think its my psu
 

GregoryDude

Honorable
May 16, 2015
79
17
10,565
10
Another thing you can do is go into your motherboard bios, look for the graphics setting in there and ensure it is set to "auto" or "peg". If it is set to "igfx" or integrated graphics, your discrete video card may not work.
 
Jan 26, 2021
21
0
10
0
Another thing you can do is go into your motherboard bios, look for the graphics setting in there and ensure it is set to "auto" or "peg". If it is set to "igfx" or integrated graphics, your discrete video card may not work.
My gpu is working now but there is a squeak sound before my display goes off. I can still hear songs. Guess its my gpu or psu need to check though
 
Jan 26, 2021
21
0
10
0
So my gpu shows good idle temperature, is fine i guess but when im using my pc, i hear a squeaking sound monitor goes black and boom no display. If i turn my pc off and turn it on immediately no display but if i wait for sometime, it gives display works on for sometime and then same thing again. I do need to troubleshoot on my friend’s pc and check if its my psu mobo aur psu but i need a few days as i have exams going on and need a fix asap, has anyone faced this issue? Icute 500w psu rx 5502gb intel h61 mobo and i5 2400 dont judge on the pc pls ik its old
 
Jan 26, 2021
21
0
10
0
So my Pc used to work fine and all but now it goes black screen every now and then. I thought it was GPU but i just checked it on another PC and it is working perfectly fine. PC works fine without gpu on my pc. Is it my Mobo, RAM or PSU thats failing? Idk which of those i should replace and I can't afford three.
 

ASK THE COMMUNITY

TRENDING THREADS