Question GPU problems following case fire

Jul 19, 2019
1
0
10
0
Might sound a bit dramatic however I was using a 2 x molex to 8 pin adapter to run my RX480. Had been working flawlessly for a couple of months until on the weekend I smelt something whilst playing and after a few minutes of wondering what it was I checked inside my PC to see that one of the molex connections on the adapter had started melting and the wires had also started turning black. Game was still running fine but I shut down the PC immediately by just pulling the power plug.

The PSU was an older Thermaltake Toughpower Cable Management750W which back in 2006, Johnny Guru gave a higher rating. It only had 2 x 6pins though hence the adapter.

I decided to replace the GPU and after doing some wattage calcs, purchased a Corsair CX550M.

After putting that it, it all seemed fine but when playing my chosen game F1 2019, it would freeze on a white, grey or black screen with a buzzing noise after about 5 minutes. No other response so reset required. This is repeatable by running the F1 2019 in game benchmark where it usually fails in the 5 lap benchmark test. Once it passed the first 5x lap loop only to fail in the second. I've tested in the older F1 2018 game which Ive played 300 hours and that did the same thing which its never done before so its not the game but its the benchmark I'm using.

Things I've tried.
  • Putting the RX480 in my other machine with similar specs and it ran with no problems on loop for 4 hours.
  • Put the RX570 from my other machine in this machine for 3 hours and it ran with no problems.
  • In doing the above I've tried different drivers on both machines with both DDU and not. Driver is not the issue.
  • Ran memtest in my machine for 8 hours with no problems.
  • Put a different PSU in, albiet a lowly Raidmax Thunder V2 735W and it got through about 5 loops then crashed on the 6th.
I'm at a bit of a loss why the RX480 doesn't work in my machine but does in the spare, yet the RX570 works fine on mine. I'm still not convinced that its not the new PSU despite the other crashing as well so will perhaps try putting the new PSU in the other machine along with the RX480 to see how it goes. Will also try the PSU in the spare, in my machine, also with the RX480. Apart from this, not sure what it can be. Is a bit odd.
 

ASK THE COMMUNITY

TRENDING THREADS