[SOLVED] GPU smelled "hot" after gaming for a few hours, smelled similar to when you turn on a heater, etc. ?

_danielpwils01

Reputable
Feb 18, 2017
131
0
4,690
1
It wasn't necessarily a burning smell, but it was a smell similar to when you turn on a heater for the first time, that's the best way I can describe it. I have an XFX 5700 DD ULTRA, and I noticed it's been getting hotter as of late. During this particular session, temps rose to 83C and junction was 97C, definitely warm but not necessarily cause for concern. What do you guys think?
 

kubacs

Reputable
May 7, 2018
185
6
4,715
23
It wasn't necessarily a burning smell, but it was a smell similar to when you turn on a heater for the first time, that's the best way I can describe it. I have an XFX 5700 DD ULTRA, and I noticed it's been getting hotter as of late. During this particular session, temps rose to 83C and junction was 97C, definitely warm but not necessarily cause for concern. What do you guys think?
Yea you probably should repaste it, possibly swap the fans out, or just run them at higher speeds.
 

JWNoctis

Prominent
Jun 9, 2021
391
87
490
55
It's similar, because it's the same smell of heated electronics and plastic that was not baked out at lower temperatures. Pretty interesting given the age of the card, though!

You may want to dust off and repaste it, just in case.

EDIT: For the record, I thought it was a GeForce FX 5700 at first.
 
Last edited:

kubacs

Reputable
May 7, 2018
185
6
4,715
23
It wasn't necessarily a burning smell, but it was a smell similar to when you turn on a heater for the first time, that's the best way I can describe it. I have an XFX 5700 DD ULTRA, and I noticed it's been getting hotter as of late. During this particular session, temps rose to 83C and junction was 97C, definitely warm but not necessarily cause for concern. What do you guys think?
Yea you probably should repaste it, possibly swap the fans out, or just run them at higher speeds.
 

JeffreyP55

Distinguished
Mar 3, 2015
81
7
18,545
1
It wasn't necessarily a burning smell, but it was a smell similar to when you turn on a heater for the first time, that's the best way I can describe it. I have an XFX 5700 DD ULTRA, and I noticed it's been getting hotter as of late. During this particular session, temps rose to 83C and junction was 97C, definitely warm but not necessarily cause for concern. What do you guys think?
Dead Rodent? LoL
 

ASK THE COMMUNITY