Question GPU suddenly dead

Jan 18, 2021
1
0
10
0
All of a sudden, a couple of days ago, GPU appears to have stopped working. I am on my last legs on the issue and already set for a refund but looking at the GPU shortage (and that I got a good price for the GPU originally, and that i have only used it for 3 months) I would still like to see if there is anything more that can be done.

Specs:
GPU: XFX RX 5700XT 8GB
CPU: Ryzen 7 10700
Motherboard: MSI X570 Gaming Edge
PSU: 650w

Problem:
Basically, PC was booting but there was no image coming to the monitor. I first checked the cables. None of the display ports where working, tried with an HDMI as well but nothing. The HDMI cable was from another pc so it is working ok.

I then took the GPU out and reinstalled it, plus checking all the power connections where ok and that nothing got loose. No luck

Then i tried my old GPU ( a 710). System booted correctly and just installed the Nvidia GPU.

I used the other PCIe slot to connect the 5700xt but it just didnt detect the gpu at all. Power comes in to the gpu (blue lights on the gpu) but no fans moving or anything. Nothing on the device manager..as if it is just not there.

I reinstalled the driver and even rolled back a windows update or two but nothing.

In the meantime I noticed this accumulation of white/green stuff next to the pcie slot of the GPu. I dont have a water cooling system nor is there any thermal paste residue anywhere else. I've been trying to upload the image but for some reason i keep getting an error so putting the link instead Image

Help me, Tom's HARDWARE, you are my only hope..
 

ASK THE COMMUNITY

TRENDING THREADS