Question GPU usage 0% in task manager while in-game + WMI Provider high CPU usage in same game

Aug 24, 2019
4
0
10
0
I know the WMI Provider Host is not GPU related but I wanted to include both since they started happening together and the WMI thing occurs only while playing this one particular game which has the -0% GPU in task manager.
Tom's hardware forum posts always helped solve little things throughout the years, on a quick google search, first time creating a thread myself because I'm out of ideas.

Windows 10 Home 64 bit.
Intel Core i5-7600K CPU @4.2Ghz
16GB Ram.
Gigabyte Z270X-Ultra gaming Motherboard.
GPU is NVIDIA GeForce GTX 1070.


Recently there was a windows update, which my computer felt like downloading even though I disabled automatic updates many many times now, but microsoft doesn't like it's user's choosing I guess.
Ever since that update about two weeks ago, to Windows 10 Home. Version 1803 (OS Build 17134.950) these problems started to occur.
I bought the game Monster Hunter: World few days after the windows update, so I can't tell if the same problem occurred prior, but here's the deal:

View: https://i.imgur.com/zEboYDj.png


You can notice two things in that screenshot, WMI provider spiking in CPU, while the game (which usually takes 90% of CPU) is using 0% GPU in task manager.
This happens ONLY when I'm in this particular game... I could be playing it, having a youtube video running on the other monitor, and suddenly I feel a drop in FPS, game starting to stutter and the FPS reading goes from about 70~85 to 60 and quick slips to 30's. Obviously we know why.

***Note that WMI doesn't spike ALWAYS when the game is running, for example I'll play 4 hours straight, and then suddenly feel a drop in FPS,
so I alt-tab to open task manager and I see WMI gradually using more and more CPU, usually capping at about 20~30% and staying there.
***When I alt-tab from the game to desktop, "Desktop Window manager" in taskmnger is using 20~40% GPU to draw the game window, as alt-tabbing throws the game into windowed mode. but when I tab-in back to Fullscreen mode GPU consumption all across the board drops to 0% again.

I understand this background process is essential so I can't just stop it, restarting it sometimes does the trick, takes a few restarts from the 'Services.msc' and I few 'End task' clicks until it finally calms down a disappears from the task manager. The process is called "Windows Management Instrumentation".

As for the GPU I want to mention this ONLY happens in this game, just as a quick test I launched a different game (Battlerite) and it displayed normal GPU usage
in the task manager.

I know MHW is heavy on the CPU and I know that it's not possible for MHW to run purely on my CPU and draw 90~100fps as it does (out of combat), so it MUST be using GPU
infact, I used EVGA's Precision X1 to monitor GPU temperature.
Temperature goes from 45c idle to about 60c presumably in work, and Power under the "Target" title goes up to ~80% while ingame.
But something still feels weird to me.


I will list things I've already tried doing about each of the problems:

GPU 0% task manager: I've tried:
-Onboard GPU is turned off from BIOS.
-Reinstalling the game.
-Setting PhysX from Automatic to GTX 1070 in NVIDIA Control pannel.
-Uninstalling all previous drivers using DDU , deleting GeForce Experience and downloading remotely the latest driver from their site. (Which boosted my FPS by 20~ steady)

WMI Provider host: I've tried:
-Restarting the service (It's only a temporary solution)
-Searching for Errors of WMI Provider Host via the Event Viewer, I'll expand on that:
I have found a few instances of errors and searched for their PID's in the "Services" tab in the task manager,
90% of the error PID's the Event Viewer reports don't exist in the task manager, can't find a matching PID, so I assume it's a momentary process that is now gone...
the other 10% I do find, are processes related to BitDefender Total Security which I'm using, all of them are minor background processes which after a google search I realized aren't needed so I DISABLED them too from Services.msc, but WMI still spikes, all the errors it reports now come from services\tasks that I can't see running in Task Manager so I don't really know where they come from.... their PID's are usually high numbers like 133498 (6 digits, while most PID's are 4~3)


Am I forgetting any details?
I searched through youtube and google, through forums and everything related the keywords I was looking for, no solution.
Thank you in advance for reading.
 
Aug 24, 2019
4
0
10
0

ASK THE COMMUNITY

TRENDING THREADS