Question GPU usage drops to 0 and causes stuttering

Nov 26, 2020
9
0
10
0
So i recently bought a GTX 960 2 GB, today I gave it a try and everything seemed to be working fine until 5 hours of usage. Then the GPU usage started to drop randomly on games like Overwatch, Sekiro and it's causing really annoying stuttering.
Here are my specs :
I5 3450
8 GB DDR3 1333 MHz RAM
GTX 960 2 GB MSI OC
Gigabyte H61MA-D2V motherboard
a really crappy 400W psu (is that the case?)
500 GB WD Blue HDD
I am hoping to find a solution, this started to occur once i swapped the GPU for the 960, i was previously using a HD 5670 GPU.
 
Last edited:
Nov 26, 2020
9
0
10
0
No. I used AMD cleanup utility and then installed the GPU along with installing the drivers from the official NVIDIA page. Should I uninstall them with DDU? If so can you guide me, cause I dont wanna mess anything up as I still have the AMD folder and I dont think its fully removed.
 
Nov 26, 2020
9
0
10
0
Update : I updated my BIOS, reinstalled windows, used DDU and installed fresh drivers, defragmented my disk and it still happens for example in Overwatch tho it's only after a few games. The first game is normal. Resident Evil 2 stutters whenever i load and do something new like shooting or entering a new location. Any advice?
 
Nov 26, 2020
9
0
10
0
RAM usage not even close to maximum. I play on low/medium with some effects turned on. It could be the hdd.
Im talking about Resident Evil 2 here, Overwatch eats up a lot of ram, really close to 8 gigs but stutter happens also in RE2.
It's weird cause it doesn't occur in the first two matches of Overwatch.
And yeah, stutter only occurs when something new happens, like a new effect or a cutscene is loading.
 

ASK THE COMMUNITY