Question Gpu usage fluctuating only in Main menu Metro Exodus Enhanced

litwicki23

Distinguished
Sep 19, 2009
515
1
18,995
1
Hi my new pc.

12900K with NZXT KRAKEN X73

2x16GB DDR4 KINGSTON DDR4 3600MHZ in GEAR 1

RTX 3090 Ti Gigabyte Gaming

Aorus Z690 Elite DDR4 bios F5

SSD 1 TB NVM PCIE

I went from Aorus Z490 and 10850K to 12900K and Aorus Z690 Elite DDR4.
Metro Exodus Enhanced.
So problem is that only in MAIN MENU gpu usage is fluctuating like crazy - between 75% to 95% and lagging. And clock jumping between 1980-2070mhz. Temps are fine. When i load a game usage is stable 95-99%.

But on my previous 10850K i had stable gpu usage 99% in main menu. So why not now in main menu only on 12900K? thanks





I am using 1440P ultra,DLSS QUALITY,Ray tracing ULTRA.

found it
https://www.reddit.com/r/pcmasterrace/comments/riwhyo View: https://www.reddit.com/r/pcmasterrace/comments/riwhyo/metro_exodus_enhanced_edition_seems_to_have_a/
 

Lutfij

Titan
Moderator
I went from Aorus Z490 and 10850K to 12900K and Aorus Z690 Elite DDR4.
Did you reinstall the OS after the platform migration?

Aorus Z690 Elite DDR4 bios F5
Your board has two more BIOS versions pending update, update to them and see if the issue persists.

Make and model of your PSU and it's age?
 
Are you still on Windows 10, which lacks the Thread Director of Win11 for scheduling of the upper-mid range/high end Alder Lake P vs. E cores...? (Not sure just how much I'd stare at or bother to investigate CPU usage during a menu, anyway, barring any other issues, of course...)
 
Last edited:

ASK THE COMMUNITY