Question GPU WONT BOOT UP power on sometimes once in a fullmoon(sapphire amd rx 570 4gb )

Aug 22, 2021
2
0
10
0
So i had my card for around 3-4 years in year 3 it started giving me problems when i installed my new psu i bought from ebay a second hand one, it didnt boot up for a while becuase i had to replace motherboards after i figured out the psu was faulty but gpu wasnt damaged i tested it on my other pc. Sometimes it will magically come on and sometimes the fan spins and comes off after 5 seconds. i know about pc repairs but not that much about components so i opened up my card followed some tutorials, used a multi meter and tested all the stuff the guy on youtube did and nothing was shorted out, i applied some thermal paste on the dye and it magically worked until this morning, i was playing a demanding game last night before turning my pc off and would resume gaming this morning but sadly ddint power on again. i tried the gpu on my mining rig with a 750 wat psu and didnt power on with that also 8 pin was connected perfectly so i think its a problem with getting power to the gpu becuase if the card was bricked the fans would be spinning but it wouldnt work or display any signal but in my case i played a game with it last night ultra graphics 1080p and it worked fine unil i powered off my pc so i think its a power fuse problem in the card any help would be grateful to me. what to do or i could diy repair it myself if i get help .
 
So i had my card for around 3-4 years in year 3 it started giving me problems when i installed my new psu i bought from ebay a second hand one, it didnt boot up for a while becuase i had to replace motherboards after i figured out the psu was faulty but gpu wasnt damaged i tested it on my other pc. Sometimes it will magically come on and sometimes the fan spins and comes off after 5 seconds. i know about pc repairs but not that much about components so i opened up my card followed some tutorials, used a multi meter and tested all the stuff the guy on youtube did and nothing was shorted out, i applied some thermal paste on the dye and it magically worked until this morning, i was playing a demanding game last night before turning my pc off and would resume gaming this morning but sadly ddint power on again. i tried the gpu on my mining rig with a 750 wat psu and didnt power on with that also 8 pin was connected perfectly so i think its a problem with getting power to the gpu becuase if the card was bricked the fans would be spinning but it wouldnt work or display any signal but in my case i played a game with it last night ultra graphics 1080p and it worked fine unil i powered off my pc so i think its a power fuse problem in the card any help would be grateful to me. what to do or i could diy repair it myself if i get help .
could you give a gpuz screenshot of your gpu? is the card bios modified from a mining rig?
 
Aug 22, 2021
2
0
10
0
no its the default bios i plugged it into my mining setup to test the gpu on that motherboard unfortunately the card doesnt last 5 seconds after booting into windows i got it to spin but now its shutting down after 5 second into windows black screen
 

ASK THE COMMUNITY