• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question GPU Won't Display Despite Me Making Sure Everything Works Properly and Together

elitemasta3000

Prominent
Oct 16, 2018
27
0
540
1
I have an HP pre built that I removed the GPU from. I sold the GPU as I rarely game anymore. I Decided to put my GTX 650 in which has a slightly lower TDP. The GPU won't display picture despite the fact that I have removed all drivers, Made sure the pc works without the GPU, made sure the GPU/PSU are working and compatible by putting them both in a system with a 3700x (it somehow booted fine despite the PSU being 300 Watts) Because of this test I know the GPU and PSU both work and are not damaged. I also updated the bios.

Specs:
i5 7400
8gb ddr4 Ram 2400 Mhz
1 tb hdd
300 watt 80+ bronze PSU
HP mobo
HP case
GTX 650
 

dotas1

Reputable
Dec 5, 2015
1,218
75
5,790
197
A prebuild low wattage PSU is not fit to power anything beside the hardware that was installed in the system when it was bought. Try another PSU (higher quality and wattage preferably) in your system and tell us how things go.
 

elitemasta3000

Prominent
Oct 16, 2018
27
0
540
1
A prebuild low wattage PSU is not fit to power anything beside the hardware that was installed in the system when it was bought. Try another PSU (higher quality and wattage preferably) in your system and tell us how things go.
Tried a 650 80+ bronze corsair, still didn't work.
 

ASK THE COMMUNITY

TRENDING THREADS