Question GPU worked before reboot.

Mar 7, 2020
3
0
10
0
Hello,
I upgraded my PC today, but I seem to have a problem with my GPU.
My GPU is XFX RX580 8GB.
On my Old specs (Intel core 2 Quad Q8300, PCIE 16x 1st gen) pc never showed any signal on my monitor.

NEW SPECS:
i5 9400F,
1x8GB DDR4 2666MHz,
512GB SSD,
650w thermaltake berlin pro RGB PSU,
Gigabyte H310M S2H 2.0

Today, after scoring the upgrade, at first time startup nothing worked, so i swapped RX580 with my old GTX750 Ti, which booted fine. Then I turned off the pc, swapped GTX 750 with RX580 again.
It finally happened, the pc booted, gpu worked.
I tried installing GPU drivers, I don't think they were installed succesfully. ( Note that I did uninstall Nvidia drivers with DDU ). So I uninstalled my RX580 drivers with DDU, without shutting down or restarting the pc.
I downloaded drivereasy, searched for all missing drivers, it showed a lot of drivers for my motherboard. Radeon adrenalin wasn't opening for me, so I believe i need to update mobo drivers.

( I haven't updated them yet )

Because when I uninstalled AMD drivers via DDU and not shutting down, my taskbar was gone, desktop was gone, only opened apps remained. So I decided to reboot pc. Windows key wasn't workimg, so I shut the pc down with power on/off button.
Unfortunately, I heard no POST beep when I tried to boot the pc up.
Fans were spinning, keyboard and mouse had RGB, GPU had blue LED on(means it has power), but monitor got no signal.
How come the GPU doesn't work after a reboot?

I removed CMOS, Reseated GPU twice, removed all cables except HDMI and PSU.
Note that I'm 100% certain I'm plugging HDMI in the GPU and not mobo.

So I used old GPU (GTX 750Ti) and everything was working, post did make a beep, i got into windows, monitor had signal on. I had a windows recovery saved before i uninstalled Nvidia drivers, so I used the recovery and still no signal on my RX580.
I hope I've explained every detail I did.
Oh yes, I even got to gaming with the RX580, pushed up to 140 frames on highest settings in the forest, so everything was working as it should be.

Any suggestions what I should do?
Thank you,
Davis.
 

ASK THE COMMUNITY

TRENDING THREADS