Question Gpus wont start on my pc

May 2, 2022
4
0
10
0
Hello!
A few days ago I turned on my pc to find out that I had no video. Checked everything I could and didn't find anything suspicious, except that my GPU (MSI RX5500 XT 4GB) fans were not spinning while my pc was booting, as it normally used to do.

We tested my gpu on my brother's pc and it works perfectly. Then we tried his completely working gpu (Asus RX580 8GB) on my pc and it doesn't work.

Everything else on my PC seems to work (CPU fans, chasis fans, hdd leds and MoBo leds are all on) Also, his gpu has a white led next to the psu cable and it's on.

My specs are:
CPU: AMD Ryzen 3 3100
MoBo: Asus Prime B450M-A II
PSU: Cougar VTE 600 80 Plus Bronze
RAM: Corsair Vengeance DDR4 2x8Gb

I really don't know how to troubleshoot this any further. Any help is greatly appreciated :)
 
Hello!
A few days ago I turned on my pc to find out that I had no video. Checked everything I could and didn't find anything suspicious, except that my GPU (MSI RX5500 XT 4GB) fans were not spinning while my pc was booting, as it normally used to do.

We tested my gpu on my brother's pc and it works perfectly. Then we tried his completely working gpu (Asus RX580 8GB) on my pc and it doesn't work.

Everything else on my PC seems to work (CPU fans, chasis fans, hdd leds and MoBo leds are all on) Also, his gpu has a white led next to the psu cable and it's on.

My specs are:
CPU: AMD Ryzen 3 3100
MoBo: Asus Prime B450M-A II
PSU: Cougar VTE 600 80 Plus Bronze
RAM: Corsair Vengeance DDR4 2x8Gb

I really don't know how to troubleshoot this any further. Any help is greatly appreciated :)
Either the Mobo or psu is shot test your brothers psu in the PC if it works then you have your answer if not then you still have your answer either psu or mobo
 
Reactions: sebastianlang
my GPU (MSI RX5500 XT 4GB) fans were not spinning while my pc was booting, as it normally used to do.
if there was no video output then you really don't know if things booted "normally"
Cougar VTE
i would guess that your lower quality power supply has malunctioned.

try setting your system up with a trustworthy compatible power supply and see if it still malfunctions.
 
Reactions: sebastianlang
May 2, 2022
4
0
10
0
Either the Mobo or psu is shot test your brothers psu in the PC if it works then you have your answer if not then you still have your answer either psu or mobo
Thank you for your answer and advice. We tested his Seasonic Focus+ 750 Gold 80+ PSU and on my mobo with both GPUs and they don't output any video, fans look dead as well. So I guess we narrowed it down to the MoBo being faulty.
 
May 2, 2022
4
0
10
0
if there was no video output then you really don't know if things booted "normally"

i would guess that your lower quality power supply has malunctioned.

try setting your system up with a trustworthy compatible power supply and see if it still malfunctions.
Thank you, yeah we don't know if everything is ok. But my gpu at least works on his pc. We tested his seasonic PSU on my mobo and still no video, so I guess my psu is not to blame yet. I guess I'll have to buy a new mobo
 
We tested his seasonic PSU on my mobo and still no video, so I guess my psu is not to blame yet. I guess I'll have to buy a new mobo
if it is "brand new", within 60 days or so;
contact the distributor that you bought it from and get a return/refund process started.

if past that time but still in manufacturer warranty;
contact the manufacturer and file for an RMA.
 
Reactions: white.a.drew

ASK THE COMMUNITY