Sep 26, 2021
4
2
15
0
Hello,

Yesterday I got a new GPU, since then my display keeps turning black for about 2-3 seconds and then back to normal without hampering any process. Videos keep playing, games keep running, no indication that there is anything wrong with drivers crashing. It only happens on my main screen MSI 27" 165Hz curved monitor. And there seems to be a pattern in the time frame, about 10/15 minutes between blackouts.

I did some stress tests with it and this didnt trigger any reaction, it happens under full-load(drawing about 250w), and under no-load(drawing ~10-15w)
I switched from a Sapphire Nitro+ 5700XT SE to a MSI 2080 TI Gaming x trio 11G.

Thanks for the help!

My specs:

AMD ryzen 5 2600x
MSI x470 Gaming plus
MSI 2080 TI Gaming x trio 11G
32gb G.Skill Aegis
Gigabyte GP-P750GM(I know the explosive PSU)
MSI Optix G27C4 27
 
Last edited:
Hello,

Yesterday I got a new GPU, since then my display keeps turning black for about 2-3 seconds and then back to normal without hampering any process. Videos keep playing, games keep running, no indication that there is anything wrong with drivers crashing. It only happens on my main screen MSI 27" 165Hz curved monitor. And there seems to be a pattern in the time frame, about 10/15 minutes between blackouts.

I did some stress tests with it and this didnt trigger any reaction, it happens under full-load(drawing about 250w), and under no-load(drawing ~10-15w)
I switched from a Sapphire Nitro+ 5700XT SE to a MSI 2080 TI Gaming x trio 11G.

Thanks for the help!

My specs:

AMD ryzen 5 2600x
MSI x470 Gaming plus
MSI 2080 TI Gaming x trio 11G
32gb G.Skill Aegis
Gigabyte GP-P750GM(I know the explosive PSU)
MSI Optix G27C4 27
Try this step by step (read until end):
  • Disconnect from internet
  • Uninstall gpu driver DDU, both nvidia and amd if amd driver didn't get uninstalled yet (just do it one by one, amd first, then nvidia, use clean and do not restart for both of them).
  • Uninstall all the processors on device manager (should be 12 on yours, also when it asks for restart, click on no) like this:


  • Restart the pc to bios, and update to the latest bios. Then go to bios again after update and load default or optimized settings then shutdown.

  • boot up to windows and install the latest AMD Chipset driver, reboot, go to power plan, choose amd ryzen balanced, and connect to internet.

  • Install the latest nvidia driver.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did) and make sure ram is on slot 2 and 4 if you use 2 sticks. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Also test the system using another good psu that'll hold up, and see if the problem still pesists.


  • And check windows update (and optional updates) if there is any and install them (except chipset in optional update). Enable hardware accelerated graphics scheduling (available in the latest windows update) in graphics settings and reboot, it should be like this:
Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 
Sep 26, 2021
4
2
15
0
Try this step by step (read until end):
  • Disconnect from internet
  • Uninstall gpu driver DDU, both nvidia and amd if amd driver didn't get uninstalled yet (just do it one by one, amd first, then nvidia, use clean and do not restart for both of them).
  • Uninstall all the processors on device manager (should be 12 on yours, also when it asks for restart, click on no) like this:


  • Restart the pc to bios, and update to the latest bios. Then go to bios again after update and load default or optimized settings then shutdown.

  • boot up to windows and install the latest AMD Chipset driver, reboot, go to power plan, choose amd ryzen balanced, and connect to internet.

  • Install the latest nvidia driver.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did) and make sure ram is on slot 2 and 4 if you use 2 sticks. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Also test the system using another good psu that'll hold up, and see if the problem still pesists.


  • And check windows update (and optional updates) if there is any and install them (except chipset in optional update). Enable hardware accelerated graphics scheduling (available in the latest windows update) in graphics settings and reboot, it should be like this:
Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
Tnx for the Reply!

What I tried and worked was to change my monitor from 165hz to 60hz when using 2 monitors and the problem disappeared. and when I have only monitor connected I can have at at 165hz without issue. Would this still be connected to drivers(i already had a clean sweep on the drivers before i installed the card). I did see that i used a branch on one of the 8-pin connectors and not the main cable, while the 6-pin and second 8-pin are 1 main and its branch.
 
Sep 26, 2021
4
2
15
0
I solved the issue.

I thought that i had Display port 1.2 but I only have 1.1 so the cable couldnt do 165hz at 1080p. Now i switched it to 144hz 1080p and no issues at all. Dont know why the amd card didnt set me on 165hz but it seems to work now. Ill order a 1.2 DP cable and see what it does.
 

ASK THE COMMUNITY

TRENDING THREADS