• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Graphics card driver update -> Can’t boot into bios or safe mode

Jun 6, 2020
1
0
10
0
Hi!

I’ve lurked a ton of threads on this topic, but can’t find any type of solution.

Graphics Card - ASUS GeForce GTX 1060 6gb
Motherboard - ASUS Prime Z270-AR


I updated the GPU through a utility (I know, won’t make that mistake again!) last night. When I woke up this morning it was permanently stuck in the ASUS splash screen. Since then I’ve done the following troubleshooting steps

  1. Turning it off and back on again
  2. Disconnecting everything and reconnecting
  3. Tried using a different monitor connection (HDMI -> DVI)
  4. Connecting the monitor directly to the motherboard HDMI port
  5. Jumping the CMOS twice
  6. F8 into safe mode
  7. F2/Del into BIOS
Nothing has worked and no matter what I do I can’t force it into BIOS or safe mode.

Are there any steps I’m missing?
 

ASK THE COMMUNITY

TRENDING THREADS