Graphics Card No Display

5kittlesaregood

Reputable
Jun 14, 2014
2
0
4,510
0
I installed a graphics card about two weeks ago. It is a NVIDIA Geforce 7600 GT 512MB. Apparently when I turned my desktop on today, some of the characters were yellow instead of the normal white on bios setup. Also, when it loads up the OS, it stops displaying on the monitor. I was wondering if this was a problem with the card? How would I fix this without buying a new card?
 

HeavenKidz

Reputable
Apr 21, 2014
121
0
4,710
5
you have the same problem like me...at 2012 i installed the 9600gt for a few week the card is run pretty good but when it going to the two months the 9600gt is stuck while i play game it cant be out to the windows and i must force restart to solve the problem..the 9600gt is dead by my poor quality psu because the poor quality psu can damaged your pc component :) or maybe your card getting hot while you playing the game,try to check your psu and your 7600gt temprature both of the problem can damage your 7600gt :)
 

HeavenKidz

Reputable
Apr 21, 2014
121
0
4,710
5
if you feel your cpu is getting hot try to open side of your casing it can be more air circulation to your cpu component,if you worried about dust you can add more fan to your casing it helps you getting more airflow...and don't forget check your psu what kind your psu is a 80+ modular psu or not ;)
 

HeavenKidz

Reputable
Apr 21, 2014
121
0
4,710
5


i think...it means your graphic card was damaged hmmm let's try this steps...try to reinstalling the driver or replace the old driver to the new driver or try to remove your graphic card from motherboard and clean it maybe it can helps you :)
 

ASK THE COMMUNITY