Question Graphics card not working after disabling CSM

Status
Not open for further replies.

MylesMor_

Reputable
Apr 10, 2017
5
0
4,510
0
I've been trying to disable CSM to get Secure Boot working properly in anticipation of Windows 11. However, when I do this, I get no video output from my graphics card (GTX 1070 with latest drivers), and 4 beeps (1 long, 3 short) which indicates a graphics card error. I then have to connect HDMI to my motherboard so I get an output and can enable CSM again which makes everything work fine. I've been pulling my hair out the last week trying to figure out what's wrong, but seemingly very few people have this issue and I can't seem to find a fix. Any help would be much appreciated.

GPU: GTX 1070
Motherboard: Z270-E Gaming
 

Lutfij

Titan
Moderator
If CSM is enabled, you're going to have to disable CSM, enable UEFI boot, then reinstall your OS, making sure Fast Boot and Secure are disabled at first. Once the OS is installed, you can restart the system, get back into BIOS, then enable Fast Boot and Secure Boot. You should look into BIOS and see if the option for PTT is available in BIOS(that's your TPM module, mind you).
 
Reactions: MylesMor_

MylesMor_

Reputable
Apr 10, 2017
5
0
4,510
0
If CSM is enabled, you're going to have to disable CSM, enable UEFI boot, then reinstall your OS, making sure Fast Boot and Secure are disabled at first. Once the OS is installed, you can restart the system, get back into BIOS, then enable Fast Boot and Secure Boot. You should look into BIOS and see if the option for PTT is available in BIOS(that's your TPM module, mind you).
Thank you, I've been considering just reinstalling but I've heard other people just converting their drive from MBR to GPT and it working fine? Is there any likely reason my graphics card doesn't work in this scenario?
 

MylesMor_

Reputable
Apr 10, 2017
5
0
4,510
0
With windows 10 you can use mbr2gpt utility to convert OS drive from MBR to GPT.
Not necessary to reinstall windows for this.
Would the drive still being MBR cause the graphics card to not work with CSM disabled though? I assumed that only affected whether Windows would boot, whereas I get no output and 4 motherboard beeps...
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS