Question Graphics card not working, integrated graphics only working in safe mode and when all graphics drivers disabled in device manager.

Jul 1, 2021
1
0
10
0
This PC has been working well for years now. Soo I tried to plug in a different monitor earlier today. It worked, I was gonna get a cable to set it up as a second monitor. I plug my old one back in and everything seems fine. I jump into a game, and every so often it starts flicking to a black screen for 2-3 seconds and then back to normal. I thought it was a cable connection issue so I went to the back of the PC to plug it in better. That's when the monitor turned completely black. I fiddle with it a bit more, it returns to working, but flicking to black every so often again. The last time I tried toying with it, it just turned to black and didn't wanna work.



Now I'm stuck here, it works in safe mode, and it works normally if the monitor is connected to the integrated graphics, but only if both (1070ti and motherboard graphics) drivers are disabled. Everything is still being detected, graphics card seems to be working, but in device manager, it shows no monitor but one. The "Generic PnP Monitor". Or the plug n play monitor, from what I've gathered.



I've tried many things including fully wiping all possibly conflicting software (DDU), such as the GeForce display drivers, and reinstalling it, while offline so windows doesn't install some drivers it prefers to no avail. Any ideas?
Sidenote, I do have MSI afterburner installed. I've seen here and there that this might cause issues?

Processor Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz 3.50 GHz
Installed RAM 16.0 GB (15.7 GB usable)
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H1
OS build 19043.1052
Motherboard Z97 Guard Pro
 
Last edited:

ASK THE COMMUNITY