Question Graphics Card Not Working !

Oct 6, 2020
2
0
10
0
Im not the best with sentences punctuation nor do i have the time to do it so this might be a continuous sentence!
So I built my computer and i tried plugging in my gtx 1660 geforce xc graphics card in and it didnt work i didnt get no display or anything!
But when i plugged in my geforce gtx 960 it started working straight away! Which i thought was weird!
So i took it to the pc shop and luckily he had his build in the back so we tested his 1660 super and it didnt work aswell so i know my graphics card isnt bad!

i updated bios and did alot of stuff just will not work PLS HELP!

I have a ASUS Prime z490-A
i7 10700 cpu
2x8 16gb ram pny xlrb
and those 2 graphics cards
500 gb memory and 2 tb hdd i will list them when i get off work

PLS HELP ME WHAT DO I NEED TO DO!
 
edit: didn´t see the his 1660

plug in the gtx1660 into the 1st PCIe slot, reset the CMOS, plug in the monitor only into your GTX1660, not the motherboard.

be sure the PCIe power is plugged into the GTX1660

which power supply are you using?

any leds on while trying to boot?

try a minimum setup:
motherboard, cpu with cooler, gtx1660, PSU, monitor, keyboard
 
Oct 6, 2020
2
0
10
0
edit: didn´t see the his 1660

plug in the gtx1660 into the 1st PCIe slot, reset the CMOS, plug in the monitor only into your GTX1660, not the motherboard.

be sure the PCIe power is plugged into the GTX1660

which power supply are you using?

any leds on while trying to boot?

try a minimum setup:
motherboard, cpu with cooler, gtx1660, PSU, monitor, keyboard

i have a 750 evga power supply and i tried and still did not work :(
and yeah i get led lights and my pc actually turns on i just dont get any display graphics card is running all my stuff is running in my build only thing that doesnt work is my screen its black!
 

ASK THE COMMUNITY

TRENDING THREADS