Question Graphics card suddenly not detected

Nov 22, 2020
4
0
10
0
Hello week ago my PC starting to suddenly no signal when playing games. And after that its randomly no signal every time my pc turned on. Even when im not in gaming. And now my Graphic card not started even in my bios its pcie not detected my graphic cards, i checked on device manager its not detected.
But sometimes when im turn on my PC my graphic card is detected and worked but then suddenly it black screen no signal then not detected again.
When using igp and plugged in my monitor on mobo it start flawlesly and no problem.

Is it my graphic card is dead, or my mobo PCIe slot is the problem. ?

Thing i tried :
- uninstall and reinstalling my
driver
- reset CMOS, reseating my
graphic card, even repaste it.

My spec
CPU : intel core i5 8500
RAM : dual channel 8 GB Crucial
Technology and
Teamgroup DDR4
2666mhz
MOBO : MSI H310M PRO- VDH
plus
GPU : Amd RX470 HIS
PSU : Aerocool lux 550W 80+
bronze
Windows 10 latest version

I still cant try my card to another computer and test my PC with another graphic card because in my place no other PC or another Graphic cards.

Any help appreciated. Sorry for my bad english
 
Nov 22, 2020
4
0
10
0
Does the system work normally when using the iGPU instead of the graphics card?
Yes it was normal on IGD even its booting with IGD when my graphic card is not detected. I already set my graphic default to PEG so if my PCiE graphic card is by chance normal my monitor is then no signal when still plug on hdmi on motherboard and must change it to plug in my ext graphic card.
 
Nov 22, 2020
4
0
10
0
Last time this happened to me, my power supply was bad, make sure the graphics card is getting power.
My psu is normal i already used my pc almost a year and half and its no problem playing games and editing video. Its started last 2 week suddenly my monitor is lost signal but my PC still on. So i force restart it then back in normal. But 3 days ago it started no signal so often and then now my graphic card, even not starting and detected on my bios.
 
Nov 23, 2020
4
0
10
0
Happening at me also. But one thing different is I have another GPU card which is no need to give additional power. It woks well on my Mainboard. It seems my GPU card which need to give additional power one is dead. Not sure yet PSU has error or not.
 
Nov 22, 2020
4
0
10
0
Happening at me also. But one thing different is I have another GPU card which is no need to give additional power. It woks well on my Mainboard. It seems my GPU card which need to give additional power one is dead. Not sure yet PSU has error or not.
I cant test my mainboard PCIE yet because i dont have other GPU to test. So now the error its beetwen mainboard pcie slot, The GPU itself or PSU that cant give the power my GPU need then ?
 

ASK THE COMMUNITY

TRENDING THREADS