Question Graphics Card was Not Detected / No Display (But now working)

Mar 13, 2022
1
0
10
0
Backstory: Few months back my PC was not booting I checked and found that a RAM stick was causing it so I cleaned it and it worked. This thing happened again few weeks back when I was playing game and blue screen of death came. I did the same as before but this this time it worked only once later ram got wasted. So for few days I was gaming on just 1 X 4gb ram it was working fine but later games would freeze for brief moment ( Deus ex, Dying Light). I thought This was because of low RAM as it was working fine on low spec games. So I added another RAM and it was working fine (Deus ex was was glitching though)

Problem:
Later that same day when I turned on my PC it was giving no display turns out GPU was not detected (though LED and Fans were working) and my IGPU was giving display through VGA

I removed CMOS, reinstall drivers (did not worked)
Cleaned my GPU (using rubber/eraser) and PCI slot and put it back and this time both GPUs were not giving display

I thought my GPU was dead but today I gave it another try

Turned on PC same as before no display turned it off and turned it on again it started giving display


Question:
I just want to know what could be the problem ?
Is it going to kill my GPU in near future ? as I lost the RAM before
What should I do to prevent this ?

Possible Reason
Dust


Specs:
i5-3470
Seasonic 500w 80+ PSU
ASUS B75m motherboard
12 GB RAM
Sapphire Rx 470 4gb
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS