Green Tint system wide

Nigredo

Reputable
Nov 24, 2014
2
0
4,510
0
Hello fellow users,

I have a problem since this morning when I started up my system: green tint.

Prior to my scheduled system shutdown, no changes were made in the graphics settings and the system shut down with the settings i used during the weekend.

On Friday last week, I replaced my old HD6950 with a gtx 970 and overall enjoyed the weekend with that card. My monitor is a BENQ XL2420T and is connected from the 970 to the monitor via mini-DP to DP.

I have this green tint the whole time, e.g on POST, in BIOS, in safe mode and regular win 7 64bit.

I replaced the DP cable with a dual link DVI to no avail. I reinstalled the old 6950 and still have the green tint. I tested the onboard graphics card also, still green tint. I uninstalled the drivers properly by uninstalling them via the "control panel" in windows and then with display driver uninstaller (guru3d) in safe mode.

I also did a driver roll back and all setting are default.

The monitor's own menu displays its colours correctly and when turning it on the test screen show its usual colors of the benq logo. In addition, green is very predominent, yet strong red and blue colours can be determined in games and such.

System Specs:
AMD Phenom II X6 1090T @ 3,4
8 GB Corsair XMG RAM 1333
Asus M4A88T EVO / USB 3.0
Thermaltake 630W PSU
Asus Xonar Essence STX
256 GB Crucial SSD M4

Personally I have my eye on the motherboard or the PSU, however both GFX cards have similar power consumption which is why tend to disregard this option.

I fear, this time I am at loss and hope to gain some input from you guys.
 

ASK THE COMMUNITY