GTA V Hitching

VermilionNeko

Honorable
Apr 24, 2014
172
0
10,680
0
Does anyone have any ideas/suggestions on what could help fix hitching in games? Or is there really nothing that can be done?

With GTAV, and countless other open world games, it always seems to hitch when driving around the city at 60FPS. This hitching is when textures/assets etc. stream in whilst playing, which causes the frame rates to drop and then go back up giving a horrible, distracting stutter. I bought an SSD for such games, and, while it helped The Witcher 3, it's made no difference for games like GTAV or The Vanishing of Ethan Carter. I'm running out of ideas for things to try and alleviate the problem. It can't be my RAM, surely?

I currently have an MSI GTX 970, 8GB RAM and an i5 4670K. Capping the frames to 30-35 seems to be the only solution I've found at giving me a smooth, stutter-free experience. But I should be able to play these games at 60FPS. :(
 

spdragoo

Splendid
Herald
Everyone is having the identical problem, including people with Haswell i7-based machines loaded with lots of RAM & VRAM.

It's the curse of open-world games: the larger area to draw means more objects. More objects means not only more for the GPU to draw, but also for the CPU to track. More items to track means more time to process the data. More data processing means it takes longer for each item individually. More time means lower FPS.

You have a decent system, so if you're really wanting to lock in the 50-60FPS as a minimum you should experiment with either turning down the resolution or turning down the details. Either one reduces the load on your CPU & GPU, which will keep reduce the effect of the FPS dips...but you won't be able to completely eliminate it.
 

VermilionNeko

Honorable
Apr 24, 2014
172
0
10,680
0
As depressing as it is, I think you're right. "/ Though I have read of some people saying they're able to run the game at 60FPS without a problem. o_O I have experimented with different settings, and, apparently, if I put the texture quality to normal, that reduces the hitching a bit. Which is strange as, even when it's on very high, my VRAM usage is only 2500GB of the 4GB.
 

ASK THE COMMUNITY

TRENDING THREADS