[SOLVED] GtaOnline Pop in Texture

May 27, 2020
8
0
10
0
My textures are not rendering properly, buildings and roads are invisible most of the time and stuff keeps popping in.

specs:
asrock rx570 4gb
ryzen 3 32000g(overclocked to 3800mhz)
Corsair Vengence 2666mhz 2x8gb

What I have tried before making this post:
Switching game to ssd
Vertify game files
Changed dxlevel
Changed gpu drivers and rollback too( 20.2.2, 19.12.2 and 20.1.3
Make cpu affinity max and process high in task manager
Updating bios
Changed power settings from balanced to high performance

I really can't find any solutions. Please help me. This problem only started to happen after march. It did not happen before March.
 
Last edited:
My textures are not rendering properly, buildings and roads are invisible most of the time and stuff keeps popping in.
It's the way the game is coded,it's made for consoles not for windows.
Changing the affinity or priority for the whole game doesn't do much you have to slow down the main thread so that the other threads that render all the stuff can finish before the main thread goes on.
View: https://www.youtube.com/watch?v=VN-mdoMDuSQ
 

Jay_dog

Prominent
Apr 14, 2020
739
104
590
18
specs:
asrock rx570 4gb
ryzen 3 32000g(overclocked to 3800mhz)
Corsair Vengence 2666mhz 2x8gb
What graphics settings? Because your specs are pretty low.

You overclocked your CPU but not your RAM? Ryzen CPUs need high speed ram and 2666 is not going to help your CPU at all.
 
May 27, 2020
8
0
10
0
What graphics settings? Because your specs are pretty low.

You overclocked your CPU but not your RAM? Ryzen CPUs need high speed ram and 2666 is not going to help your CPU at all.
4x Msaa
Vsync on
max distance scaling, population variety and density
Texture very high
Shader high
Shadow high
Anisotropic Filtering x16
the rest is normal/off
(I tried putting everything to normal but there isnt any difference in texture popping in)
 

Jay_dog

Prominent
Apr 14, 2020
739
104
590
18
4x Msaa
Vsync on
max distance scaling, population variety and density
Texture very high
Shader high
Shadow high
Anisotropic Filtering x16
the rest is normal/off
(I tried putting everything to normal but there isnt any difference in texture popping in)
Vsync off and everything else lower. 4GB of VRAM is not enough for the settings you have listed especially max distance scaling, population variety and density.

What FPS are you getting?
 
May 27, 2020
8
0
10
0
Vsync off and everything else lower. 4GB of VRAM is not enough for the settings you have listed especially max distance scaling, population variety and density.

What FPS are you getting?
Honestly, it fluctuates. Most of the time I'm getting 60fps but after playing for some time it goes down and up ranging 45-60
 
My textures are not rendering properly, buildings and roads are invisible most of the time and stuff keeps popping in.
It's the way the game is coded,it's made for consoles not for windows.
Changing the affinity or priority for the whole game doesn't do much you have to slow down the main thread so that the other threads that render all the stuff can finish before the main thread goes on.
View: https://www.youtube.com/watch?v=VN-mdoMDuSQ
 
May 27, 2020
8
0
10
0
It's the way the game is coded,it's made for consoles not for windows.
Changing the affinity or priority for the whole game doesn't do much you have to slow down the main thread so that the other threads that render all the stuff can finish before the main thread goes on.
View: https://www.youtube.com/watch?v=VN-mdoMDuSQ
Hey man, thanks for making that video. I went on youtube previously and searched but this video did not appear. It mostly worked but there was one split second where one building didnt render but other than that it's all good!
How do I know which one is the main thread? I randomly lowered one and it kinda worked
and do I have to do this every time I open gta?
 
How do I know which one is the main thread? I randomly lowered one and it kinda worked
and do I have to do this every time I open gta?
There should be only one thread with a high % usage and priority on above normal,or anyway the main one should be the one with the highest usage.
Yes you have to do it every time you start up GTA.

And one last thing rockstar bans people for anything so there is always the danger that they could ban you for that although you are not cheating.
 
May 27, 2020
8
0
10
0
There should be only one thread with a high % usage and priority on above normal,or anyway the main one should be the one with the highest usage.
Yes you have to do it every time you start up GTA.

And one last thing rockstar bans people for anything so there is always the danger that they could ban you for that although you are not cheating.
Thank you so much bro :)
 

ASK THE COMMUNITY

TRENDING THREADS