[SOLVED] Gtx 1070 aero itx oc -new psu old fps drops

May 6, 2019
35
4
35
0
it seems the whole (CPU+Mainboard+)PSU Upgrade was for nought as the Game perfomance is still not as it's supposed to be - extreme FPS drops whilst low CPU usage and now you can't tell me it's the PSU anymore.
and the RAM usage was at 4,7GB - (happened in old games [The Witcher ONE - without nearly hitting 8GB Ram usage] and in newer games) It probably always was the Aero ITX 1070 - a unigine Heaven benchmark showed a good score BUT low FPS = 1 only average and max fps were normal. I don't know what to do anymore I probably just wasted nearly 700€ as I'm currently also facing CPU problems (different thread). don't get me wrong I'm going to add 2x 8GB ram soon, but what else could it be? I think the damn factory OC is at fault here they sold it as Aero ITX but specs (GPU-Z) showed it is Aero ITX OC (two different GPU versions)

I'm going to contact the support but I don't have much hope (they recommend RMA - send gpu in - they test it - sending it back to me saying it is "working" ignoring fps drops <- at least I was told it would go like this. So, help please? Anyone?
 

ebosss03

Notable
May 1, 2018
436
7
865
44
That sounds like what would happen if you got cheap 8GB ram. Also what watt is the PSU? Cheap RAM has much latency and can overall cause problems on high settings. RAM will almost never hit 100% because it then will try to compress as much data as possible. But when you compress data the CPU has to work much harder. I had cheap 8gb RAM and had the same issue.
 
Reactions: jamdrelik
May 6, 2019
35
4
35
0
I hope you are right.
I recently upgraded my psu from unbrand to seasonic focus 650w platinum, that thing is pretty neat.
you are right about my current Ram being cheap, I'll probably go with kingston or corsair 2x 8gb 2666 and hope this is going to finally solve my problem. but the gpu is the thing worrying me. after upgrading from i5 8400 (which somehow underperformed too) to i7 8700k (and new psu+mobo) I saw literally no performance boost.


Edit: A few days ago my 16GB Corsair RAM arrived and wow: +10-20 fps (and more, before AC Odyssey couldn't even run stable at 45fps.
Now, on Max settings @1080p: min 33fps ; average 65fps ; max 93fps - all in town and erverything's stable.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS