Question GTX 1070, random pixelated lines flickering for a split second when connected to Displayport and setting the frequency above 75hz

mossi

Distinguished
Feb 27, 2013
237
5
18,695
1
GTX 1070, random pixelated lines flickering for a split second when connected to Displayport and setting the frequency above 75hz
This started happening randomly on Saturday as the screen going black for split seconds (like when it's updating drivers) but it kept doing it constantly.
I switched to HDMI on Saturday and forgot about it until this morning when I switched it back to Displayport.
The random black screen cut outs have now been replaced with this flickering which I'm not sure if I'm describing correctly.

It keeps on doing something like random flickering lines (sometimes pixelated) that appear for split seconds like when a cable is not connected properly but I have tried it on multiple occasions and it's securely connected.
It's only doing this with my monitor's native resolution which 2560x1440 at 95hz.
It doesn't do it at 75hz for some reason.. as I soon as I drop it to 75hz they stop immediately..

My monitor is this:
https://www.laptopsdirect.co.uk/electriq-27-qhd-1440p-95hz-freesync-hdr-monitor-eiq-27mq95fshdru/version.asp
And other than this issue the last couple of days I haven't had any other problem with it..

I don't have any other high refresh monitors to test it with Displayport unfortunately so I'm all out of ideas... any suggestions?

For the record I've updated the drivers to the latest version (512.77)
It was doing the same with 512.59 as well..
 

ASK THE COMMUNITY