Question GTX 1650 SUPER isn't running on 75Hz

Sep 11, 2020
42
2
35
0
I upgraded my system from RX 560 to GTX 1650 Super. I have a 75Hz FreeSync monitor and It was working perfectly enough with my RX 560 at 75Hz. But I use 1650 SUPER now and it shows my Hz as 74,924 Hz. This is not a problem but when i use this setting its almost life 30Hz refreshing rate. When I take it back to 60 Hz its kinda normal. I use DisplayPort and every single software is up to date.
 

kiss-method

Respectable
Oct 26, 2018
435
29
2,390
106
Which monitor do you have exactly? Maybe it’s just not compatible

my freesync 1 monitor would not post any picture with nvidia card, no matter efficient setting. They all have compatibility complex.....
 
Sep 11, 2020
42
2
35
0
Which monitor do you have exactly? Maybe it’s just not compatible

my freesync 1 monitor would not post any picture with nvidia card, no matter efficient setting. They all have compatibility complex.....
Yea I accepted my fate. It's AOC g2260vwq6. Some guy said in one of the other threads that some monitors aren't compatible if it isnt an AMD card.
 

Math Geek

Champion
Ambassador
my 1650 super hits 144 hz on my AOC 24G1 so it's not likely the card itself not being capable.

it's possible it is the monitor not being compatible but i'd do some searching for that specific model and see if anyone has how to do it on that specific model. could be some sort of weird config needed or maybe it worked after installing one of those add-on software. never know what might get it to work. chances are someone else has the same monitor and did the footwork to get it working on their system and shared it with others.
 

kiss-method

Respectable
Oct 26, 2018
435
29
2,390
106
Yea I accepted my fate. It's AOC g2260vwq6. Some guy said in one of the other threads that some monitors aren't compatible if it isnt an AMD card.
Someone posted that your monitor does support the use of nvidia cards.

Could you try capping your max FPS to 72 with Riva tuner or other software/in game limiter. Looks like this worked for many people.

since you came from an AMD card, you could also try using DDU app to clear all of your video drivers and try fresh again
 
Sep 11, 2020
42
2
35
0
Someone posted that your monitor does support the use of nvidia cards.

Could you try capping your max FPS to 72 with Riva tuner or other software/in game limiter. Looks like this worked for many people.

since you came from an AMD card, you could also try using DDU app to clear all of your video drivers and try fresh again
I cleaned my AMD drivers with AMD driver removal tool. I have really, really bad memories with DDU so im not going to use it. But im gonna try the rivatuner and report back. Thanks
 
Sep 11, 2020
42
2
35
0
Someone posted that your monitor does support the use of nvidia cards.

Could you try capping your max FPS to 72 with Riva tuner or other software/in game limiter. Looks like this worked for many people.

since you came from an AMD card, you could also try using DDU app to clear all of your video drivers and try fresh again
I downloaded Riva Tuner and capped my FPS to 72. But i guess i have to give some details before asking for more help. I checked my monitor Hz on a YouTube video. And when i use 1920x1080 75Hz its like a 30 fps video. Now when it comes to my question. Do I use 75 Hz setting and set Rivatuner FPS cap to 72? I suppose so.
 
Sep 11, 2020
42
2
35
0
Someone posted that your monitor does support the use of nvidia cards.

Could you try capping your max FPS to 72 with Riva tuner or other software/in game limiter. Looks like this worked for many people.

since you came from an AMD card, you could also try using DDU app to clear all of your video drivers and try fresh again
Well I did a big test and used Battlefield 4, Chrome and Microsoft Edge. The reason videos looked like 30 FPS when on 75Hz was because I turned off hardware accelleration. So I had to turn it on. When I tested the overall quality in Battlefield 4 I could definitely see the difference between 60Hz and 75Hz. If someone asks just tell them that they should turn hardware acceleration on.
 
Reactions: kiss-method

ASK THE COMMUNITY

TRENDING THREADS