GTX 680 Boots to Black Screen After Driver Install


Mar 29, 2017
I was browsing (on chrome, windows 10) and everything froze (couldn't move mouse cursor, everything unresponsive) and after restart the computer booted normally though the windows loading screen and instead of a login screen the monitor said no signal and shut off while the computer itself stayed on and continued to run.

I then booted into safe mode, removed the drivers, resintalled them, and when it didn't fix the problem, tried to research the problem online with a lot of potential fixes listed but no luck.

If I remove the graphics drivers, the computer detects the card as a "microsoft basic display adapter", but if i install nvidia drivers it detects the card as a GTX 680.

I noticed that in the device manager, while connected to the GTX 680, the monitor shows "generic non-pnp monitor", while connected to the onboard graphics it correctly displays as a Benq monitor with the correct model.

I also noticed that while the monitor was connected to the GTX 680, when entering the bios, the menu appears too large for the screen. Initially i thought this may be some problem with the bios, but when i move a mouse cursor to the sides of the screen it moves the display as if the bios is "aware" it isn't being wholly displayed. This was not happening before these problems started. When I connect through onboard graphics and enter the bios, the bios is displayed properly with no weird scaling issue.

However, when starting Windows in safe mode the whole screen is rendered properly, albeit in very low resolution that can't be changed.

I tried booting into safe mode, removing the drivers with DDU and ccleaner, and manually installing drivers from NVIDIA, which didn't fix the problem.

I tried uninstalling the graphics card via the device manager, didn't fix.

Tried disabling the onboard graphics via the device manager (and the BIOS), didn't fix.

Tried plugging the monitor into onboard graphics and it worked normally, although I would obviously rather not use onboard graphics. Also tried plugging the monitor into a laptop and it was both detected and displayed normally, so probable not a monitor problem.

Tried updating mobo drivers and BIOS, didn't fix.

Tried disabling "fast boot" in windows, didn't fix the problem.

Tried using HDMI and DVI on all the available ports after driver install, didn't fix the problem. Don't have a display port cord.

Tried on a fresh install of windows, didn't fix the problem.

It occurs to me that it could be some sort of resolution problem with the card itself, although I don't know why it would say no signal instead of out of range if that were the case, and I don't know why it would persist through a clean install of drivers and a fresh install of windows. It is also odd that it would affect the bios menu as well if it were just a windows issue.

I am going to try unseating the card, cleaning it, and reseating it, although it isn't dusty and hasn't had any temp problems to this point, although obviously something either software or hardware related caused Windows to freeze the first time before these problems started.

I don't feel like this is a windows problem because the problem has persisted through a clean install of the drivers and a fresh windows installation. The monitor works perfectly when connected to other devices, so it's not that. It could be a motherboad issue, but onboard graphics works normally and everything else seems ok other than this graphics problem. I would try another GPU in the slot but unfortunately I don't have one handy at the moment.

Is there anything else I can try? Would this be a problem flashing the gpu bios could potentially fix?

Thanks to anyone who made it this far.


OS: Windows 10
gpu: EVGA GXT 680 ftw+
mobo: asrock z77 extreme 4
cpu: i7 3770k
mem: 32gb corsair vengeance