GTX 760 AC4: Black Flag Physics Nvidia FPS.

Florescu Florin

Honorable
Dec 12, 2013
24
0
10,510
0
I have a GTX 760 and i play AC4: Black Flag ON MAX SETTINGS I MEAN MAX but when i turn physics on it suddenly drops the FPS. So my question is: Why does physics eats my FPS ?

Please help!
 

wbrian200

Honorable
Sep 29, 2013
25
0
10,540
1


Physics just does that...it fairly demanding of the GPU.

With that said, I've been experiencing (along with numerous others) inconsistent frame rates with black flag. Sometimes it will run 60+, other times it drops down to 30. I was just now playing with settings in the game, and combined with some research from previous searches I've done, I now have my game running beautifully.

First, if you haven't, you need to download D3d overrider, and set it to force V-sync and triple buffering for ac iv (and honestly it doesn't hurt to just go ahead and do it for all you games). I had read about this in the past, and I just did it a few days ago, and the difference is vast.

Now my game is nearly maxed...the only things I have cut back on are AA, which I set to TXAA 2x instead on 4x, Shadows are set to Soft (medium), and God rays are low. Everything else is all the way up (including physics), and V-sync is off because it being forced in D3d overrider. Now my game is running smooth as silk. I'm running a GTX780, so you may need to scale back a tad bit, but the thing that was making the biggest difference for me was just the change between TXAA 4x and 2x. Hope this helps!

 

Florescu Florin

Honorable
Dec 12, 2013
24
0
10,510
0
I must say, i didn't think my FPS will improve so much after i installed that program. I only lowered the AA to TXAA 2x and the rest high as possible. I get around 40-50 FPS which is great, thank you so much !
 

wbrian200

Honorable
Sep 29, 2013
25
0
10,540
1


Glad I could help! I really don't care for less than 60 fps (the difference in smoothness is just very apparent to me) which is why I'm scaling back a little more than you. Just one suggestion, in AC IV, god rays on low and soft shadows on medium have minimal to no impact on graphical quality. This is just my opinion/personal preference, but I really think you could have an even better overall experience if you cut those 2 things back as well. Hopefully the developers will work on some PC optimization for this game soon so we can truly max with no issues ;) Happy gaming!
 
honestly i don't know the game have so much problem since i was able to get 60FPS all the time with everything max out except AA set to FXAA. this is before the PhysX patch. personally i haven't tried the game with physx enabled yet since i haven't touch the game after done i'm done with the story. but i'd expect it will have huge impact in performance. maybe it has something to do with PhysX APEX integration into the game engine since the game did not use PhysX as it's main physic engine (actually the game engine were using Havok)
 

ASK THE COMMUNITY

TRENDING THREADS