Question Gtx 780 not showing up in device manager not even as a basic display adapter

Jul 16, 2019
11
0
10
0
I tried it all everything i can do with my current setup i have a dell server psu that ive had forever its 730 watts or i have a AMD HD 6870 in my computer right now now and it works great and OC's to its extremes easily and that thing eats a lotta power so my question is why wont the Zotac GTX 780 i bought do anything but spin thr fans. I thought maybe it was the adapters i had in there but i dont think its that. I may take it to a computer store to be tested un a few other sytems but I'd rather know myself for just to know if this happens again i do not think its dead for because the fans spin but i do get a beep or two when booting with it in if i remember right. Thank you for your time
 
Last edited:
Jul 16, 2019
11
0
10
0
Also it will not let me install the drivers because of this I used to gace a GTX 1070 in it and it ran in there like a dream
 
Jul 16, 2019
11
0
10
0
I tried it all everything i can do with my current setup i have a dell server psu that ive had forever its 730 watts or i have a AMD HD 6870 in my computer right now now and it works great and OC's to its extremes easily and that thing eats a lotta power so my question is why wont the Zotac GTX 780 i bought do anything but spin thr fans. I thought maybe it was the adapters i had in there but i dont think its that. I may take it to a computer store to be tested un a few other sytems but I'd rather know myself for just to know if this happens again i do not think its dead for because the fans spin but i do get a beep or two when booting with it in if i remember right. Thank you for your time
 

ASK THE COMMUNITY