GTX1060 won't work on my H61 motherboard

mirceaizvoran

Distinguished
May 8, 2007
67
0
18,630
0
Hi there, I just got myself a GTX1060 and apparently doesn't work with my Foxconn H61 MXL-K motherboard. As I turn on the PC the image freezes in less than a second and I cannot do anything about it, cannot even enter BIOS the only operation that works is CTRL+ALT+DEL. Last year I tried it with a GTX960 but with the same results :s ...i even tried with a second and different GTX960 but did the same...i put them in a older spare AMD motherboard...SAME :( . I use a decent Fractal Design 600W PSU with my current AMD HD5870(more power hungry than GTXs) and works perfect. Does anybody have any idea what to do?
Many Thanks,
IZZI
 

cin19

Titan
Moderator
MERGED QUESTION
Question from mirceaizvoran : "GTX1060 won't work on my H61 motherboard"



 
No idea.

But whenever I see mention of a Foxconn motherboard I think 'prebuilt'. (I had a prebuilt PC which used a Foxconn motherboard.) If so there's the possibility of the BIOS being locked and wouldn't accept certain hardware upgrades. I would want to eliminate this possibility first.

With older motherboards there's also the possibility of it not being UEFI, which can be a possible compatibility issue.
 

Eximo

Titan
Herald
Check to see if Foxconn has any BIOS updates for that board. About the only option.

If that doesn't work out, buy a replacement motherboard. Lots of choices, but you may have to poke around to find one.
Chipsets: H61, H67, B65, B75, H77, Z68, Z77. And the lesser known chipsets Q67, Q77, P67.
 

Similar threads


TRENDING THREADS