Jared485

Honorable
Jan 6, 2013
284
0
10,810
So I received my card today, gigabyte gtx680 overclocked, the one problem is it has 3 fans and there are 2 screws connected to 2 plastic clips on each end. Well on the end that you do not screw to the case , the 2 black clips are broken, from shipping I'm sure. I just dot want to turn around another 1-2 weeks of waiting time and was wondering if there was some type of adhesive safe around computers that I could use to put the pieces back together?? If anyone has used or heard of anything that'll work it'd be awesome of you could share! My main worry is that the fans s&g down now and are hanging of just that one side. 1: it'll mess with the cooling because some of the fans aren't close enough to the actual card and 2: I dnt want t to snap off completely!! Please help! Thank you!
 

Jared485

Honorable
Jan 6, 2013
284
0
10,810
Well despite the damage I installed it everything run smoothly and no problems so far all the fans work also. I will post a couple pictures ASAP. I've just been waiting weeks for it and if it causes no problems and can be fixed it like to do that. Again, ill post some pictures thanks for the advice.
 

Jared485

Honorable
Jan 6, 2013
284
0
10,810
New England, United States, I meant I had been waiting to order it for a few weeks an took about a week to get here so it's just fusterating to hve it but not... If I were to send it back can I get overnight shipping there and back?
 

Jared485

Honorable
Jan 6, 2013
284
0
10,810
Lol it's my first order from newegg I order everything from amazon the same card was just out of stock, not exactly a good first impression. Haha. I will have to call and see what they can offer me.
 

Jared485

Honorable
Jan 6, 2013
284
0
10,810
Yeah, im in Maine cant get much further away lol. But it did say it went through NJ. It took about 3 days to get there and 2 days from there to here. I wont be able post pictures of it until tomorrow, it so minor that's the only reason I even though about repair vs. RMA