Question H100i v2 - issues

Sep 22, 2019
1
0
10
0
Hello guys, been scouring the forums for some solutions to this but only found partial answers that do not really help me solve this issue.
I recently purchased a h100i v2 slightly used, for a couple of months. Installed into my system, and originally the temps were fine, sitting around 25-30 idle but Corsair link could not detect it nor could windows, and it would be running at 100% (very loud) so I rebooted and checked all my connections. When I reconnected it and rebooted suddenly the temps went through the roof, up to 100 degrees.
I have checked bios ( although there really isn’t any fan control with this mobo) and changed every fan I can to manual full speed, only sys 1 and 2 can be changed like this. Tried cpu into those fan slots instead of header, reseated about 10 x, the pump is making a slight vibration but only slight, one pipe gets warmer near the cpu plate, the other stays cold.
The device manager in windows gives me a code 43 error for a device ( presume it’s the cooler) and I cannot find the Corsair driver for this anywhere to try to install it over the top to make that driver run.
Corsair link does not detect in the slightest however led is on the cooler, and the link cable is plugged into front usb 1 header on mobo ( tried on 2 and 3 also).
Any help is appreciated. Specs as followed:
I7-4790k 4.6ghz
Gigabyte z9p-d3 mobo
24gb ram
gtx 1070
650w EVGA supernova g2
1tb hdd
2x ssd drives 1 for boot
Edit: bios is report 0rpm for the cpu fan speed too. Whether this is something to do with it not detecting the pump and not allowing it to run properly I’m not sure. Defo can feel a slight vibration and hear the water start to move when booting up though.
 
Last edited:
It looks to me like your pump is no longer working as you should get a reading from the CPU fan speed for the actual pump speed. Try doing this, connect the pump cable to the CPU header and then the 2 fans to 2 FAN separate headers and not via the USB cable. Then check the pump speed via the BIOS and if it is still 0RPM...then pump is not working.
 

Crosslhs82x2

Respectable
Aug 12, 2017
772
118
2,290
45
Hi i have 3 corsair coolers
In your corsair link does it show your pump and fan speeds?
Did you reboot after install?
Under where you saw code 43 did you see a option to Enabled ?
Are you running IQUE?
as the fans and pump speeds will be in ique.
There is a possibility of a air bubble that doesn't want to move.
I have had to use older versions of the link 4.
Options for uninstall and reinstall.
https://www.corsair.com/us/en/downloads

First download ccleaner if you don't have already.
On the current version you have
Open the install software it will use the built in uninstaller.
When it asks if you want to remove config files click yes and when finished reboot.
Then run ccleaner regestry cleaner.
Then run a older version of link 4
Install and REBOOT
When running again go into device manager look in the usb devices
Under the first few devices check for a 3.1
That is unknown or needs enabled.

(I am away from my computers so i can't tell you exactly what it is and won't be back around them for 5 more days).
 

ASK THE COMMUNITY

TRENDING THREADS