xsnowstormx

Commendable
Dec 24, 2017
4
0
1,510
0
So, I have an Asrock H110M-HDS, and I want to upgrade from 8th gen Intel (i3 8100) to 9th gen. (i5 9400f)
Now, you'd say "But not even 8th gen is compatible on that old thing!"

Well, I don't know why, but "it just works" as Todd Howard would say.
It's not a fake cpu, it's the real thing. I got literally 1 point less than the normal in one attempt at Cinebench R20, both single and multiple core scores were the same.

I had an old version of the bios, and it worked just fine. Yet, when I updated it, my pc got bricked. I fixed with a bios programmer by applying the version before last. So I guess maybe the newest update is what makes these mobos not work with after 8th+ gen CPUs.
Now, has anyone had the same experience? Will I be able to update to 9th gen without changing my motherboard? I'm kind of in a very tight budget so I can't really afford to buy the new CPU without selling the old one.
 
Honestly, the real reason that 100 and 200 series boards cannot support 8th or 9th gen CPUs is at the BIOS level. The sockets really aren't changed in any major way that makes older boards incompatible, despite what Intel wants you to think.

Heck Linus from LTT was able to run an 8th gen mobile 6 core on an older h110 board (iirc) but it required a modded bios.

Also, it can work in reverse. Linus reviewed a 300 series motherboard that worked with 7th gen CPUs. I believe there was a version of that board that supported from 6th to 9th gen CPUs.

I am surprised yours worked without a modded bios, however.
 

ASK THE COMMUNITY

TRENDING THREADS