Question Half of my RAM is not usable ?

Oct 27, 2020
12
1
15
0
When I open task manager, I see that i have 16gb RAM, but only 8gb is usable. Some is also hardware reserved. When going into my BIOS, it says that I only have 8gb RAM, even though it recognizes that i have 2x8gb RAM sticks installed. I have a photo of my BIOS screen. I would really like you guys to help me.
 

General Kenobi

Respectable
Sep 19, 2018
706
143
2,140
32
When I open task manager, I see that i have 16gb RAM, but only 8gb is usable. Some is also hardware reserved. When going into my BIOS, it says that I only have 8gb RAM, even though it recognizes that i have 2x8gb RAM sticks installed. I have a photo of my BIOS screen. I would really like you guys to help me.
Is you ram seated on correct slot if you are not sure check your manual. Have you come across this issue now or from the beginning. Mention your pc specs
 
Oct 27, 2020
12
1
15
0
Is you ram seated on correct slot if you are not sure check your manual. Have you come across this issue now or from the beginning. Mention your pc specs
I built the PC almost 2 years ago, and I never noticed the problem before, but it has probably always been this way. I just came across it by chance a week or so ago. I have only 2 RAM slots in my motherboard, and I removed both sticks and reseated them today - but this did not solve the issue. My specs are:
AMD Ryzen 2600 processor
MSI B450 gaming plus motherboard
MSI AMD Radeon rx580 8gb Armor graphics card

thank you for such a quick response! Also, today my PC has become pretty much unusable; the CPU spikes to 100% as soon as I just simply open the Task Manager. A week ago I could play League of Legends with graphics maxed out at 130-190FPS, and now i can barely get 50fps at the lowest graphics settings. I also struggle to even load up a game of League. Is this possibly connected to my issues with the RAM?
Sincerely thank you for responding to my post!
 

General Kenobi

Respectable
Sep 19, 2018
706
143
2,140
32
I built the PC almost 2 years ago, and I never noticed the problem before, but it has probably always been this way. I just came across it by chance a week or so ago. I have only 2 RAM slots in my motherboard, and I removed both sticks and reseated them today - but this did not solve the issue. My specs are:
AMD Ryzen 2600 processor
MSI B450 gaming plus motherboard
MSI AMD Radeon rx580 8gb Armor graphics card

thank you for such a quick response! Also, today my PC has become pretty much unusable; the CPU spikes to 100% as soon as I just simply open the Task Manager. A week ago I could play League of Legends with graphics maxed out at 130-190FPS, and now i can barely get 50fps at the lowest graphics settings. I also struggle to even load up a game of League. Is this possibly connected to my issues with the RAM?
Sincerely thank you for responding to my post!
Have you done some troubleshooting? Check this forum https://forums.tomshardware.com/threads/windows-10-only-using-half-of-installed-ram.2558441/
 
Oct 27, 2020
12
1
15
0
Try 1 stick at a time. Could be the RAM slot too. So test one stick at a time on each slot. You will see if it's a stick or a slot or not at all.
I just finished trying 1 stick in each of the slots, and then the other stick in each slot as well. Both sticks and slots work I assume, since my BIOS screen regocnises all options. However, it also regocnises when i have both sticks inserted, it lists them both on the BIOS screen but still says it only has 8gb??
 
Oct 27, 2020
12
1
15
0
Zip archive needs to be extracted first.
Then run LiveUpdate installer. After it is installed, run Liveupdate.
I have now extracted the folder, leaving me with another folder containing a txt.doc and some other document i cannot open (it takes me to the windows app store). Do I have to download the program LiveUpdate? If so, where would I do that? Sorry for being such a dumbass when it comes to tech - I know it must be frustrating to deal with. Ty for helping continiously
 
I have now extracted the folder, leaving me with another folder containing a txt.doc and some other document i cannot open (it takes me to the windows app store).
Do I have to download the program LiveUpdate? If so, where would I do that?
You have downloaded something other than LiveUpdate installation. Probably BIOS file.

In MSI support downloads link (from post #10)
select utility,​
select windows 7 x64 OS,​
find Live Update 6 download link;​
download zip archive,​
extract it,​
run LiveUpdate installer,​
run LiveUpdate.​
 
Oct 27, 2020
12
1
15
0
You have downloaded something other than LiveUpdate installation. Probably BIOS file.

In MSI support downloads link (from post #10)
select utility,​
select windows 7 x64 OS,​
find Live Update 6 download link;​
download zip archive,​
extract it,​
run LiveUpdate installer,​
run LiveUpdate.​
Done. However, I do not see a way to install the BIOS update file that i previously have downloaded. I assume MB driver has something to do with my motherboard, and I do see several MB driver updates available after pressing "Scan". What to do?
 
Oct 27, 2020
12
1
15
0
Done. However, I do not see a way to install the BIOS update file that i previously have downloaded. I assume MB driver has something to do with my motherboard, and I do see several MB driver updates available after pressing "Scan". What to do?
Okay sorry! I just presses the arrow keys in the top right corner and found a page titled BIOS UPDATE. I hit scan, and i see 1.60 (realised in march 2019) is available for update. However, I previously downloaded another BIOS file, as I mentioned in the other post, which is more recent. Should I just press download on this slightly older version anyways?
 
Jan 8, 2021
12
0
10
0
Has this ever been resolved? I'm having the same issue even after updating the BIOS.
I upgraded my AMD PC to 32gb of RAM but it's only using 16gb. Weird thing is, after I pulled the new sticks out it's only registering half of my old RAM. I've swapped slots, and resetted the CMOS and tried the Windows solutions. I have no idea why it's doing this, I built my brothers Intel computer a year ago and I just got him to check and he is also having the same issue.

Please help!
Thanks.
 

ASK THE COMMUNITY

TRENDING THREADS