"hard disc not detected!"

Sp3cialOne

Honorable
Mar 18, 2012
3
0
10,510
I recently bought a new case so I swapped all my parts over into the new case turn it on and I get "hard disc not found!" the sata cable was plugged in, I used a different sata cable, tried it in every port on the motherboard. So I started thinking maybe my hard drive just went bad, so I went and bought a new hard drive but ***... Same result "hard disc not found!" in the bios sata is set to IDE mode. Note it worked completely fine until I moved all the hardware into the new case.
 

Dogsnake

Distinguished
This is not uncommon. When you swapped the case you probably attached the HDD to a different SATA port. The boot configuration expects to find it in one place but it is not there so it reports no HDD. Also when you disassembled/reassembled everything the bios my have reset to default values. The Sata should be AHCI as this is probably the mode you were using for Win7/64. Does the HDD show in the bios? If it does, you need to then go to the bios boot order tab and set the cd drive as first and that HDD as second. Each time you changed port you would have had to do this. If luck is with you windows will start. If the file(s) that windows uses to boot have been corrupted by all the switching around, you can try using your win disc to boot from and it will try to repair the system files. If it can not do the repair you can try a system restore point. If all repair fails you will have to reinstall windows. In my opinion win7 is a bit odd as it will only let you do a repair install (one that does not change program or user settings) unless you are booted into windows. They now call it an upgrade installation.
 

TRENDING THREADS