Question Hard drive not powering on, but only while inside new PC build.

Dec 9, 2022
Hey guys, I’m new to the forum and am really needing some help with this one. I’m setting up an unraid server in my old PC case with new hardware and cannot get it to recognize/power a specific 10tb hard drive.

I got everything in the new build set up and running correctly (unraid running, but no disks yet), so I started to move my two 10tb drives from my old Synology NAS to the unraid PC – both drives were working fine at the time of removal. I immediately noticed in the BIOS that one drive was detected, while the other wasn’t. After checking a number of possibilities (listed below), I’ve found that the hard drive in question is actually not powering on. I thought for sure it was fried, but when I move it to a USB dock, it loads up just fine.

So far I’ve tried:
  • Checking and using multiple cables, both power and sata. These all function fine with other drives.
  • Formatting the hard drive, changing it from MBR to GPT and vice versa.
  • Running hard drive diagnostics via regular Windows tools & CrystalDiskInfo, the results are perfectly healthy with no warnings.
  • Updating the BIOS to the newest version and checking that the storage settings are optimal.
  • Ensuring that the m.2 drives I have installed on the mobo aren’t interfering with the sata ports I’m using, as using the second slot disables the use of sata port #2.
The only thing I’m seeing that I haven’t tried is enabling CSM within BIOS. This section is grayed out for me, as it apparently requires a graphics card, while I’m only using onboard graphics in this build.


CPU: Intel i5-11500
RAM: 16gb (2 x 8gb) DDR4 Ripjaws

Additional note: while most of the hardware is new, the PSU is from my old PC build. It’s semi-modular and I am using the cables it came with, not some random set. It’s not very old (like 2 years) and I’ve never had an issue with it.

I'd appreciate any info/suggestions!