Hard Drive or SATA controller problem?

rmarier83

Distinguished
May 15, 2010
108
0
18,710
10
Hello, thanks for taking your time in reading my problem.
So, my problem is that my Seagate 4TB HDD kept disconnecting everytime I did mass copying or moving from it. It would only reappear after a full shutdown and cold booting back to Windows (restarting the PC wasn't enough).

I figured maybe the Hard Drive was going bad so I tried copying files off there (instead of moving (cut/paste)). It lasted a little bit longer before the disconnect (about 10 minutes). Then I was thinking it might be the SATA controller going. I then put my HDD in an external enclosure and tried copying from it again and haven't had any problems now. But as of right now it's only been going for 1 hour.

While it seems I should put the blame on the SATA controller, it's just that I find it hard to believe, because to me HDD failures are usually the one to blame in this kind of scenario. Also, my Motherboard is from the Ivy Bridge era, so the shoddy SATA controllers from the Sandy Bridge era shouldn't be a problem for me (AFAIK) that and the fact I'm copying to an internal HDD. I don't really know how SATA controllers work, are they all separate for each I/O?

So what do you think I should do: Replace my 4TB, or buy a PCI-E SATA card?
 

anbu13

Reputable
Sep 9, 2014
160
0
4,760
49
Sounds like the SATA port or SATA cable problem. Try with another SATA port and SATA cable. To ensure your HDD's health you could run a S.M.A.R.T test on your HDD and verify that your HDD's health is OK.
 

Similar threads


ASK THE COMMUNITY