Question Hard Drives Keep Disconnecting

Naif Alkhalifah

Distinguished
Mar 18, 2013
11
0
18,510
0
Hello guys,
I just connected eight 10 TB hard drives to my PC through USB 3.1. I am using the Mediasonic 8 bay enclosure found here.
It's connected to the PC running Windows 10 on Asus' Z370 motherboard.
When I'm copying files to the drives (3 or 4 copy operations running at the same time while also downloading multiple files on Qbitorrent), randomly the processes are suspended as shown in the image below.



When I click on "Try Again," the processes resume normally. I have to resume Qbitorrent downloads as well since they were moved under "errorred."



Here's what I tried so far:
  • Disable "USB Selective Suspend"
  • Disable "turn off hard drive after"
  • Disable "allow the computer to turn off this device to save power"
What I will try when I get access to the PC:
  • Change USB port
  • Change USB cable (the cable is new, by the way)
Anything else I should be looking into?
 

Lutfij

Titan
Moderator
I'd try and make sure that your BIOS/firmware for both the motherboard and the enclosure are up to date. To add, make sure that you're on the latest drivers for your USB ports. You can reinstall USB drivers in an elevated command - i.e Right click installer>Run as Administrator.
 

Naif Alkhalifah

Distinguished
Mar 18, 2013
11
0
18,510
0
I'd try and make sure that your BIOS/firmware for both the motherboard and the enclosure are up to date. To add, make sure that you're on the latest drivers for your USB ports. You can reinstall USB drivers in an elevated command - i.e Right click installer>Run as Administrator.
I use Driver Booster to check for drivers. I already checked them all and updated what needed updating.
 

ASK THE COMMUNITY

TRENDING THREADS