Question Hardware Reserved RAM

Mar 4, 2023

CPU: Ryzen 5 1600 3.2GHz 6-core
MoBo: ASRock AB350 Pro4
GPU: EVGA 1660Ti 6GB
RAM: 2x8GB G.Skill Aegis DDR4-3000
HDD: Western Digital 1TB

Hi all, I have been looking to solve some issues regarding my RAM. A couple days ago my system experience a BSOD loop with Critical_Process_Died error code. I used Windows Installation Media to create a bootable USB and did a clean install of Windows 10 64-bit. Afterward, I was checking Task Manager in Windows and saw that 8.1GB of my 16GB of RAM was hardware reserved. I have no prior knowledge as to whether my hardware was reserved before but I am assuming it wasn't. I have already tried changing max memory in msconfig, tweaking VRAM settings in System Info, resetting Windows, changing PageFileAtShutdown in my registry, and every other fix you could think of in the OS itself. In my BIOS I have tried turning on my XMP profile to no avail. BIOS registers that both sticks are in their slots, but says that they are in single-channel mode, even when they are slotted into A1 and B1, the same with A2 and B2. When I slot my RAM into A1 A2, I get a BSOD loop. When I slot them into B1 B2, my system won't even boot. CPU-Z says that my RAM is in "2 x 64-bit" when I look at the channel. I don't know if this means that CPU-Z recognizes my RAM as being in dual-channel or not. The RAM sticks I have came together in a kit. In addition, my BIOS only recognizes my DDR4-3000 RAM as only being DDR4-2133, which I understand to be default. I ran MemTest today and it reported 0 errors in my memory, but maybe I didn't run the correct test? I don't know, and I'm at a loss but I would like to get help diagnosing this problem and make sure it's my RAM that's <Mod Edit> before I bite the bullet and buy a new kit. If it's an issue with my CPU or MoBo then I'm SOL because I cannot afford to upgrade those things at the moment. Thanks
Last edited by a moderator:
  • Like
Reactions: cloakedj24
Apr 1, 2023
Also, I have flashed my BIOS to the most recent version that is stable for my CPU. Unfortunately P5.80 is the last stable version for Raven, Summit and Pinnacle Ridge CPUs.

CPU: Ryzen 5 2600 3.6 Ghz 6 core
GPU: Gigabyte RTX 2060 6gb x2fan
RAM: 2x8GB Corsair Vengeance 3000mhz

¿Encontraste una solución para el problema?, Tengo el mismo problema. La mitad de mi memoria RAM, se va reservada para el hardware (8.1) y la velocidad se queda en 2133, al igual que tú, intenté con la memoria virtual, encontrar errores con la herramienta de windows para la memoria RAM, contacté con el soporte de Gigabyte para ver si podían darme la solución (porqué mi placa madre es de esa marca), pero me dijeron que no pueden hacer nada en ese sentido. Encontré otra persona que tiene un problema similar y encontró una solución, pero solo a la cantidad de memoria, no a la velocidad. El usuario es "erky" en este mismo foro, pero me preocupa que no pudo encontrar la solución a la velocidad.

Did you find a solution for the problem?, I have the same problem. Half of my RAM memory is reserved for hardware (8.1) and the speed stays at 2133, just like you, I tried virtual memory, find errors with the windows tool for RAM memory, I contacted the Gigabyte support to see if they could give me the solution (because my motherboard is from that brand), but they told me that they can't do anything in that regard. I found another person having a similar problem and he found a solution, but only to the amount of memory, not the speed. The user is "erky" on this very forum, but he worries me that he couldn't find the solution at speed.


May 2, 2014
I probably have the same issue.
I just got my MB Asus Sabertooth 990FX 2.0 from service where it has got the sound chip replaced. Just noticed that games are running slow and opened Task Managed... I was surprised that 97% of memory was consumed and just in a second I realized that I have only 7.9 of 16 GB available, the rest is hardware reserved.
Point is that system sees that all 4 DIMM slots are occupied and can recognize every memory stick put into them:

By putting it/out sticks I've figured out that all 4 memory sticks are OK (btw they all are the same from one kit), but B1 and B2 slots are not able to use inserted memory sticks, despite they being properly detected, and the system doesn't go even to the POST screen.
I have:
  • checked the CPU - all pins are OK.
  • cleaned slots and sticks from dusk.
  • reset BIOS to default (4th slot even started to detect inserted memory stick)
  • applied XMP profile (again started to see all 4 sticks but using only A1 and A2)
So, I'm out of ideas. Is it a memory controller on the CPU? Or do I just need to take MB back to service and replace slots (visually I do not see any damage)?