Hi.

At my work, I use a computer running Windows 10. Since it's on a domain and that the policy is to push (force) software/OS updates on those computers quite often.

Since I do take photos and do some drawings at work, I've be using the portable version of Gimp (from portableapps.com). This have being working just fine for long time. Last week as well.

Until today. Opening a 6MB jpg image suddenly halted and it tool like 5 long minutes before Gimp was ready to do further work on the image (some cropping, resizing, not any advanced stuff). This went just fine.
Then it was time to export the file to another jpg image. Also this operation halted and it took like 4 whole minutes when Gimp appeared to be frosed before the export dialog box appeared. And from there, everything went as normal.

This exact same problem repeated with a new image I was about to do the same operations on. When first try to open a jpg image file, the GUI frose just like before. This time, after approx. minutes I open Task manager, and just when I was about to select the Gimp process - it let go (i.e. Gimp GUI no longer frozen and I could work with the image).

As this issue repeated for third time, I decided to use task manager and just kill gimp process.

Next: My first suspicion is that there are some setting in Gimp that make this issue. So I went to the portableapps web site and downloaded the newest version of Gimp currently available (link). I wiped off all files within the last portableapps folder (both binaries and setting) and unpacked newest Gimp portable into that folder.

The result : Even worse. This time, I let it try to open a file for more than 10 minutes, but I had to kill the process. Aka - not solved.

The thing that seems most confusing about this is this is a behavior that changed during the weekend (because this wasn't a problem last week).

I believe this can be caused by some windows update, because that I cannot control (not my computer).
I hope this is just some windows cache issue, hopefully resolved by itself tomorrow.

Has anyone else experienced that issue with Gimp on Windows 10 ? Any ideas what it can be ?
 
Ok, I was able to work out when and why that happens.

Turns out Gimp doesn't like JPG files from my Sony RX100 camera.

The reason why it happens now and not before, is that I've always had a routine to optimize those jpg files upon import (used Irfanview thumbnail viewer for batch operation on many files at a time). This time however, I didn't do the optimize routine.

Problem solved, or at least I know a workaround for the issue now 🆒

Going to make a bug report for as I can replicate the problem 😎
 

ASK THE COMMUNITY