Has my M.2 SSD died? Am I giving CPR to something that's already left us?

Jan 25, 2019
1
0
10
0
Long story short:

M.2 Crucial MX300 1TB SSD has been working perfectly on my X370 Asrock Mobo for around a year and a half with windows 10.

Last week I started hear electrical whining noises during heavy GPU usage (Gaming / Crypto) that would come and go.

Yesterday my PC froze so I turned it off manually via the power.

On restart it would freeze again after 5 mins of use and then eventually even at the login screen.

Tried system restore / system repair / other options in windows 10 recovery screen to no avail.

Then tried one last system restore that was going on for 50 minutes which I thought was not working so I turned it off manually via the power again.

Current situation now: SSD is not detected in the BIOS nor via Windows 10 reinstall via a UEFI USB..

Tried restarting multiple times and reinserting the m.2 ssd and still nothing..

Has it died?
Is it another component?
Should I have waited 4 hours for the system restore?

Crucials warranty process looks like hell and I don't think it's going to be worth it..

Thanks guys.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS