• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question Have i connected up my GPU right?? im not convinced i have...

LilWhiteChris

Honorable
Sep 4, 2014
89
1
10,635
0
My PC has been working okay for a few weeks but im not convinced iv connected up my GPU using the correct cables?
1) Why is it there seems to be so many different types to connect up a gpu? (Im really struggling to find info on what cables are needed) My msi instructions where very generic and poor.

2)When people talk about 6+2 or 8 pin connectors are they also including the blank ones when they say that? for example as shown in the images, my cable im using has 8 holes but only 6 have wires in, so is that a 8pin or 6 pin??


Below is the cable im using in my system atm. the PSU end has 8 holes but 6 wires and the GPU end has one bloick of 6 with 2 jumped off of it and i have two sets of these plugged in.



I found it weird to open the box and find these cables, as i wanted cables that dont have other wires being borrowed from each other, in other words i thought it looked better if they are individual solid cores all the way back to the PSU but im not sure what to look for to buy that.

Im using this PSU:


I m not using any of the cables that came with the PSU because i also brought this replacement KIT:


In the kit i also got 3 sets of these:



Which i have not used because i would end up with extra ends dangle-ling down into my case that imo would look horrible. I also noticed that once again these have a different arrange meant of wires and holes, the PSU end has 8 Holes and 7 wires, which also made me think how iv done it is wrong, because my set up is only using cables with 6 wires in them.

This is all so confusing and its getting way in over myself. i just dont understand any of it and i want to make sure its done right.

Please any advice is welcome, i hope iv made myself clear.
 

LilWhiteChris

Honorable
Sep 4, 2014
89
1
10,635
0
No , they are extras for additional cards if you had them , The cable you are using from the first posted pic is correct.
So how i have it is okay...
What i couldnt get my head around is the fact these are 2 different sests of cables the one in the first image on the PSU end has 8 pins BUT ONLY 6 have wires in, 2 are spare. (is that right?)
and the other set's PSU end has 8pins but only 7 have wires in

So if both sets can run the GPU why are the wired differently?
 
Yes. Extensions are absolutely fine. They are just cables after all.

Fun fact: "6+2/8 pin PCI-E power connectors" supposedly has two extra pins to regulate power better. But many PSUs only do so by shorting those two extra pins to the other two pins on the 6. Some even provide blank pins (like the one you will have).
 
Reactions: LilWhiteChris

LilWhiteChris

Honorable
Sep 4, 2014
89
1
10,635
0
Yes. Extensions are absolutely fine. They are just cables after all.

Fun fact: "6+2/8 pin PCI-E power connectors" supposedly has two extra pins to regulate power better. But many PSUs only do so by shorting those two extra pins to the other two pins on the 6. Some even provide blank pins (like the one you will have).
Oh okay, so to clarify, the 8pin end from my psu actually has 2 blanks and only 6 wires at the psu end, and this is Normal?

I only ask because iv been driving myself crazy trying to figure out if my setup was correct, id basically convinced myself that it was wrong, simply because as i mentioned earlier in most build guides iv seen on the internet all you get to see is the wires going to the gpu, with their cable combs and all looking pretty neat and slick with no wires spare hanging down or wires jumping from one block to the other (like mine) i couldn't work out why my cables where physically different from all the videos iv seen and assumed id done something wrong.
 

ASK THE COMMUNITY

TRENDING THREADS