Question Have I got a faulty motherboard?

Jun 3, 2020
1
0
10
0
So I was starting to make a new build the other day heres the specs of the build

NEW BUILD
MOBO: AsROCK B450 Steel legend am4 (atx size) (The motherboard was already updated to support my CPU)
CPU: AMD Ryzen 5 3600 3.6ghz
RAM 2x Corsair vengeance LPX 16GB 3200Mhz
PSU: Cooler master 600w MWE 230v v2 (Replacement power supply after capacitor blew). The previous psu I was using was a Corsair CX600M
Graphics card: Radeon RX 570 8GB

Probably not needed but in case your interested in knowing my old build specs here they are:


OLD BUILD
CPU: Intel core i5 4460 3.20ghz
RAM: 12gb DDR3 830MHz
Motherboard: H81M-Plus
Graphics card: Radeon RX 570 8gb
Storage: Crucial CT128M550SSD1
1863GB Western digital WDC WD20EARS-00MVWB0



And for storage I just used the SSD from my previous build and hard drive, both are working before the build and after the build on my old computer as I'm waiting for a motherboard replacement.

So all my parts arrived on my birthday, I started to build the pc with all the new parts except the new powersupply, the powersupply I put in the computer was a 600w supply that I didn't realise how old it was it was a 13 year old supply, as my boyfriend gave it to me it was a spare from one of his old builds and he didn't realise how old it was, I also used it in my old build for a couple of years. I tested the pc downstairs and everything was working brilliantly, benchmarked and got great performance in games. I turned the pc off, unplugged it and carried it upstairs carefully and started to plug it in to the socket on the wall in my room, as I was testing the computer downstairs and the full time spot would be in my bedroom. I connected the keyboard and mouse and booted the pc up I noticed as I booted it there was a little pop and the smell of burning so I instantly turned it off and unplugged it from the wall. I looked at all the parts to rule out if it was any capacitors on the motherboard, none of them were swollen or exploded. once I got the courage I booted it back up again and got 3 beeps from mobo speaker and the psu fan would run 3 cycles or so then stop. I checked the PSU and the white capacitor had blown. I ended up ordering a new power supply and it arrived a day later. I installed the new power supply, the pc was working again, so I had everything turned off at the socket and plugged in my mouse turned the computer on and noticed that it was no longer working/realising I had a mouse in, the rgb wasn't working on the mouse either. I plugged it into all the other USB ports to see if it was a faulty USB and it worked in none of them. I decided to turn the computer off again and unplugged the keyboard USB and the USB for the RGB and moved it into the original USB where the mouse was plugged in and the mouse where the keyboard was plugged in. I turned the computer on and my keyboards RGB went white in the centre and started to smoke, I instantly turned it off and didn't even attempt to try to see if the keyboard was still working, it stunk like burning electrics. I also tried another mouse and that mouse is no longer working.. Do you think this is a faulty motherboard? Everything was wired correctly and it would boot into windows fine before the PSU capacitors blown and also after the replacement of the PSU, the fan was working on the CPU, the RAM was working, GPU was working. I just don't understand what went wrong?
Apologies for the long post, thanks for your time for reading though, please let me know what you think the issue could potentially be.
And as for problems with the electric in my room, I am currently using my previous build in the exact socket my new build was in, there is nothing wrong with the electrics in the house, I'm currently using the new PSU in my old pc.
 
Last edited:
Jun 20, 2020
1
0
10
0
I just want to say first of all I'm not what you would call an expert by any means... I'm in computer sciences for college I'm not done yet though and it's hard to objectively say what it is without being able to see first hand.

If the USBs are frying that would indicate to me that there is an issue with power delivery (at least for the USBs) you have one of three potential problems (at least).

It is very possible there is a fault in the motherboard, where it is shorting out your USB power lines and giving them too much power.

Similarly, you could have dropped something or laid something with conductivity across contacts at the back of the motherboard while organizing cable management by accident.

It is also possible that your motherboard and case aren't grounded and the excess energy is going into your usb headers.
 

ASK THE COMMUNITY

TRENDING THREADS