Question Have I killed my NVME drive? "A device which does not exist was specified" error. Can't delete EFI partition.

Mar 16, 2023
My drive shows up in BIOS and in Windows BUT I can't access it, if I try to copy anything over to it I get, Error 0x800701B1 A device which does not exist was specified.

I picked up a new 1TB NVME drive and tested it out as a storage drive and all was good. I was interested to see how it fared as a boot drive so I disconnected my primary drive and installed Windows 10 Pro on the new drive but then wanted to set it up as a second drive (for a short term option, I'm looking to update my setup and will eventually use it as a primary drive on another PC) so I formatted it but now I cant do anything with it as there's an EFI partition but I can't delete it.

In Minitool Partition Manager it shows as an MBR drive but won't let me do anything to it.

The disk doesnt show up at all in diskpart. When I list volume, I can see both of partitions on the disk, but can't delete the EFI partition, I get the error, A device which does not exist was specified" when I tried delete volume override.

In Disk Management there's a 100mb EFI system partition with 931.40GB showing as the other partition.

I tried the Kioxia software and it doesnt show any issues with the drive, but shows that 30.87GB is used with 117mb as unallocated and 900.53GB free.

I'm at a loss as to what else I can try? Does anyone have any suggestions please?

EDIT, I found it! Rescan Drives on Disk Management allowed me access to the drive
Last edited:
  • Like
Reactions: Zizo007