Question Having issues related to DirectX errors.

Aug 30, 2019
3
0
10
0
Hello,

I've recently updated many of my PC's internals (motherboard, processor, ram, fans/fanhub) and since I've done that I have run into a series of DirectX and .dll errors that I can't seem to fix no matter what I do. I've looked on other forums and tried almost every fix you can imagine. The first error that I've had a major issue with is I believe related to a Nvidia driver, that one is nvwgf2umx.dll. This was on an EVGA 1070 SC.

Since I tried every suggested fix for that error and nothing seemed to work it led me to believe it could just be an issue with my Ryzen processor not communicating with my Nvidia card correctly. So I went out today and bought a lower end AMD graphics card to see if that helped. I booted up the same game (Final Fantasy 14) and was then greeted with the error atidxx.dll. That card is an XFX RX 560.

I can't seem to pin this problem down and if someone could help out I would be very grateful.

PC Specs:
Ryzen 5 3600
Gigabyte X570 Gaming X
Corsair Vengeance RGB 16gb ram @3000mhz
(current) XFX Radeon RX 560 (previous) EVGA Geforce 1070 SC ACX 3.0
Corsair 750 Watt PSU
 

ASK THE COMMUNITY

TRENDING THREADS