Question Having issues with installing new hardware

Dec 2, 2022
Didn't know where best to ask help for this, so figured this subforum is the right one (?)

Alright, specs - My motherboard is old (can't afford a new one tho), it's a Intel® Desktop Board DQ67OW (if you need the link for the specifications & compatibility, just ask an I'll edit this post so it's easier for everyone to find).

I first tried a newer graphics card. My current is a GTX 460 (1gb of Video Ram). I tried put in two different GTX 970 cards, not all at once, but one at a time. The monitor I'm using is Ematic LCD, it only allows VGA & HDMI. Both however got "No Signal" from the monitor.
I plug in the old GTX 460, boots up just fine, monitor picked up the "signal", ran as normal.

Then months later I received new Ram sticks, both are DDR3 16 gbs 1333 mghz (which is what my motherboard allows). Switched out the old ones for the new ones, powered up, it gave 3 beeps (Ram problem). Removed one, and switched them around, still the same beeps. Then added in the old 8 gbs of ram, didn't beep, but then "no signal" from monitor. Then removed one of the new sticks, same thing as before, no beeps, no signal. Removed the last new stick with only the old 8 gbs of ram (just in case, its 2 ram sticks at 4gbs, the old ones) still in the board, powered on, monitor picked up the "signal", computer running fine again.

Roomie had one more idea, to pop the CMOS battery out, figuring it might be dying, switched to an ASUS battery, no power, put the old one back in, then tried the new sticks again. Same 3 beeps. So switched out the new for the old sticks again. It did refuse to work for a bit, but eventually we got it to work again.

Right now I am stumped as to what could be the issue. For some reason my motherboard refuses to accept new ram (we bought the 16 gb sticks new online), and while I have no idea how long my other room mate has owned his two 970s, my monitor still refuses to work with the newer graphics cards.

So, any ideas? I am completely stumped.
Last edited:


That board has a very early implementation of UEFI, which seems to have bugs like not being able to boot a GPT partitioned USB stick. So the first thing to try is to toggle CSM or even Legacy BIOS mode (which would require reinstalling or some trickery to avoid reinstalling) if you are currently in UEFI mode.

I should point out that modern GPUs can have some quirks on Legacy BIOS, such as my GTX 960 which has a huge 1 minute delay before POSTing, but otherwise works fine with it (perhaps some UEFI bits of the hybrid vBIOS must time-out before it'll resort to Legacy BIOS mode)

As for the RAM, support for modern 8gbit DDR3 RAM chips wasn't added until Haswell/Broadwell and their 8x and 9x chipsets, so your 6x chipset is completely incompatible. It can accept 4Gbit chips (512MB per chip) which means the largest sticks that can possibly work are 8GB per stick and then only if they are fully populated with 16 chips each. Your motherboard manual says 32GB is supported, but that's only with 4 such sticks.
Reactions: zanderfel