Having overclocking issues with 670

Status
Not open for further replies.

Gamer_Pollution

Distinguished
Nov 26, 2011
105
0
18,690
I have a Gigabyte Windforce 2x 670 and for some weird reason, when i attempt to increase the clock speed by even 20MHZ, it actaully underclocks it, from 941 MHZ to 914 MHZ according to Furmark and GPU Z. I'm kinda confused and would appreciate any help. I used MSI Afterburner and Furmark for testing, with GPU Z also. \
My specs are an i5 3570k overclocked to 4.5 GHZ, a CoolerMaster Hyper 212 Evo, an Asus P8Z77-V LE Plus, Gigabyte Windforce 2x 670, a Seagate Barracuda 3TB 7200 RPM Hard Drive, Crucial M4 128GB SSD, Patriot G2 Series 2x4 GB 1600 MHZ ram and a CoolerMaster HAF XM.
Thanks and any help is appreciated.
 

Gamer_Pollution

Distinguished
Nov 26, 2011
105
0
18,690

At stock the CPU reaches a temperature of 60 Celsuis at 100% load. Is that temperature too high?
 

SkyWalker1726

Distinguished
Oct 5, 2007
264
2
18,865
if u meant GPU :

"no it's not high @ all , Gpus limit are said to be 90~100 Celcius ...
but my 680 starts lowering the Gpu frequency @ 70
it's how the kepler was designed to be , that's how it works .
and by the way mine is a windforce too :) "

if u meant CPU :

"if after 4~5 hours of "intelburntest" ur temps are below 85 , is would say ur fine"
 

Gamer_Pollution

Distinguished
Nov 26, 2011
105
0
18,690

Really? Damn, that sucks. Though overclocking a 670 is pretty pointless anyway. Thanks!
 
Status
Not open for further replies.